api_client 1.0.2

  • Readme
  • Changelog
  • Example
  • Installing
  • 59

api_client #

Build Status Coverage Status

A schema api's client

[0.0.1] - TODO: Add release date.

  • TODO: Describe initial release.

example/README.md

Example #

Define Specification #

import 'package:api_client/api_client.dart';

Spec spec = Spec(endpoints: {
  "get_item": {
    "url": "{{api_url}}/items",
    "method": "get"
  }
}, parameters: {
   "api_url": "https://api.domain.com"
});

Middlewares #

import 'package:api_client/api_client.dart';
Spec spec = Spec();
spec.middlewares.add((Request request) {
  request.headers[Constants.HEADER_CONTENT_TYPE] =
    Constants.CONTENT_TYPE_JSON_UTF8;
});

Call APIs #

spec.call("get_item").then((response) {
  // do something with response
  // response.statusCode == 200
  // var body = json.decode(utf8.decode(response.bodyBytes));
});

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  api_client: ^1.0.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:api_client/api_client.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
18
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
59
Learn more about scoring.

We analyzed this package on Oct 21, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.1
  • pana: 0.12.21

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:api_client/api_client.dart.

Health issues and suggestions

Document public APIs. (-1 points)

61 out of 61 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Format lib/middlewares.dart.

Run dartfmt to format lib/middlewares.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
http ^0.12.0 0.12.0+2
Transitive dependencies
async 2.4.0
charcode 1.1.2
collection 1.14.12
http_parser 3.1.3
meta 1.1.7
path 1.6.4
pedantic 1.8.0+1
source_span 1.5.5
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
Dev dependencies
coveralls ^5.1.0
mockito ^4.0.0
test ^1.3.4