api 1.0.1

  • Readme
  • Changelog
  • Example
  • Installing
  • 62

A library for Dart developers.

Created from templates made available by Stagehand under a BSD-style license.

Usage #

A simple usage example:

import 'package:api/api.dart';

main() {
  var awesome = new Awesome();
}

Features and bugs #

Please file feature requests and bugs at the issue tracker.

1.0.0 #

  • Initial version, created by Stagehand

example/api_example.dart

import 'package:api/api.dart';

main() {
  var awesome = Awesome();
  print('awesome: ${awesome.isAwesome}');
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  api: ^1.0.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:api/api.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
51
Health:
Code health derived from static analysis. [more]
75
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
72
Overall:
Weighted score of the above. [more]
62
Learn more about scoring.

We analyzed this package on Jul 7, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13

Health suggestions

Fix lib/src/api.pbjson.dart. (-25 points)

Analysis of lib/src/api.pbjson.dart reported 102 hints, including:

line 8 col 27: Avoid const keyword.

line 10 col 8: Avoid const keyword.

line 11 col 5: Avoid const keyword.

line 12 col 5: Avoid const keyword.

line 16 col 26: Avoid const keyword.

Format lib/src/api.pb.dart.

Run dartfmt to format lib/src/api.pb.dart.

Format lib/src/api.pbenum.dart.

Run dartfmt to format lib/src/api.pbenum.dart.

Format lib/src/google/protobuf/empty.pb.dart.

Run dartfmt to format lib/src/google/protobuf/empty.pb.dart.

Maintenance issues and suggestions

Homepage URL doesn't exist. (-20 points)

At the time of the analysis the homepage field https://gembet.net was unreachable.

The package description is too short. (-8 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.5.0 <3.0.0
fixnum ^0.10.11 0.10.11
grpc ^2.1.3 2.2.0
protobuf ^1.0.1 1.0.1
Transitive dependencies
async 2.4.2
charcode 1.1.3
collection 1.14.13
convert 2.1.1
crypto 2.1.5
googleapis_auth 0.2.12
http 0.12.1
http2 1.0.0
http_parser 3.1.4
meta 1.2.1
path 1.7.0
source_span 1.7.0
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.2.0
Dev dependencies
pedantic ^1.8.0 1.9.1
test ^1.6.0