animation_library 0.0.2

  • Readme
  • Changelog
  • Example
  • Installing
  • new47

👏 Animation Library #

Say Thanks! Twitter

A beautiful animation widget Animation_Library.

The source code is 100% Dart, and everything resides in the /lib folder.

Show some ❤️ and star the repo to support the project #

GitHub stars

GitHub forks

GitHub followers

Open Source Love License

Build Status

CodeCov

💻 Installation #

In the dependencies: section of your pubspec.yaml, add the following line:

Version

dependencies:
  animation_library: <latest version>

Place this folder this under your top directory

Also add this section of your pubspec.yaml, and the following line:

flutter:
  assets:
    - assets/

❔ Usage #

Import this class #

import 'package:animation_library/animation_library.dart';

Flutter Animation Library #

Flare



AnimationWidget(
    type:"purple",
    width: 500,
  height:500,
  movement: "startup",
),



Flare



AnimationWidget(
    type:"purple",
    width: 500,
  height:500,
  movement: "startup",
  ),



👍 How to Contribute #

If you are interested in contributing to the project, please read Contributing guide and let us know!

Contributors ✨ #


717natsuki

📖 🤔

This project follows the all-contributors specification. Contributions of any kind welcome!

📃 License #

Copyright (c) 2020 Natsuki Kataoka
Copyright (c) 2020 <NAME OF THE DESIGN PROPRIETOR>

Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.

Getting Started #

For help getting started with Flutter, view our online documentation.

For help on editing package code, view the documentation.

0.0.1 #

  • TODO: Describe initial release.

example/lib/main.dart

import 'package:flutter/material.dart';
import 'dart:async';

import 'package:flutter/services.dart';
import 'package:animation_library/animation_library.dart';
import 'package:flare_flutter/flare_actor.dart';

void main() {
  runApp(MyApp());
}

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => _MyAppState();
}

class _MyAppState extends State<MyApp> {
  String _platformVersion = 'Unknown';

  @override
  void initState() {
    super.initState();
  }


  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      home: Scaffold(
        body: Center(
          child: Column(
            children: <Widget>[


              AnimationWidget(
                  type:"programming",
                  width: 500,
                height:500,
                movement: "startup",
              ),
            ],
          ),
        ),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  animation_library: ^0.0.2

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:animation_library/animation_library.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
6
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
47
Learn more about scoring.

We analyzed this package on Jul 3, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13
  • Flutter: 1.17.5

Analysis suggestions

Package does not support Flutter platform linux

Because of import path [package:animation_library/animation_library.dart] that declares support for platforms: android, ios

Package does not support Flutter platform macos

Because of import path [package:animation_library/animation_library.dart] that declares support for platforms: android, ios

Package does not support Flutter platform web

Because of import path [package:animation_library/animation_library.dart] that declares support for platforms: android, ios

Package does not support Flutter platform windows

Because of import path [package:animation_library/animation_library.dart] that declares support for platforms: android, ios

Package not compatible with SDK dart

because of import path [animation_library] that is in a package requiring null.

Health suggestions

Format lib/animation_library.dart.

Run flutter format to format lib/animation_library.dart.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.7.0 <3.0.0
flare_flutter ^2.0.3 2.0.4
flutter 0.0.0
Transitive dependencies
collection 1.14.12 1.14.13
flare_dart 2.3.4
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8
Dev dependencies
flutter_test