angular_youtube_player 0.1.0

  • Readme
  • Changelog
  • Example
  • Installing
  • 57

Angular Youtube iframe component #

Example #

<youtube-player [width]="800"
                [height]="600"
                videoId="nGlh4SVrsFg"></youtube-player>

0.1.0 #

  • Initial version, created by Stagehand

example/main.dart

import 'package:angular/angular.dart';

import 'src/app_component.dart';

Future<void> main() async {
  runApp(appNgFactory);
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  angular_youtube_player: ^0.1.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:angular_youtube_player/angular_youtube_player.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
38
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
40
Overall:
Weighted score of the above. [more]
57
Learn more about scoring.

We analyzed this package on Jul 2, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.9+1

Analysis suggestions

Package not compatible with runtime flutter-native of android

Because of the import of dart:html via the import chain package:angular_youtube_player/angular_youtube_player.dart->package:youtube_iframe_interop/youtube_iframe_interop.dart->package:youtube_iframe_interop/src/utils.dart->package:dart_browser_loader/dart_browser_loader.dart->package:dart_browser_loader/src/style.dart->package:dart_browser_loader/src/utils.dart->dart:html

Package not compatible with runtime flutter-native of ios

Because of the import of dart:html via the import chain package:angular_youtube_player/angular_youtube_player.dart->package:youtube_iframe_interop/youtube_iframe_interop.dart->package:youtube_iframe_interop/src/utils.dart->package:dart_browser_loader/dart_browser_loader.dart->package:dart_browser_loader/src/style.dart->package:dart_browser_loader/src/utils.dart->dart:html

Package not compatible with runtime flutter-native of linux

Because of the import of dart:html via the import chain package:angular_youtube_player/angular_youtube_player.dart->package:youtube_iframe_interop/youtube_iframe_interop.dart->package:youtube_iframe_interop/src/utils.dart->package:dart_browser_loader/dart_browser_loader.dart->package:dart_browser_loader/src/style.dart->package:dart_browser_loader/src/utils.dart->dart:html

Package not compatible with runtime flutter-native of macos

Because of the import of dart:html via the import chain package:angular_youtube_player/angular_youtube_player.dart->package:youtube_iframe_interop/youtube_iframe_interop.dart->package:youtube_iframe_interop/src/utils.dart->package:dart_browser_loader/dart_browser_loader.dart->package:dart_browser_loader/src/style.dart->package:dart_browser_loader/src/utils.dart->dart:html

Package not compatible with runtime flutter-native of windows

Because of the import of dart:html via the import chain package:angular_youtube_player/angular_youtube_player.dart->package:youtube_iframe_interop/youtube_iframe_interop.dart->package:youtube_iframe_interop/src/utils.dart->package:dart_browser_loader/dart_browser_loader.dart->package:dart_browser_loader/src/style.dart->package:dart_browser_loader/src/utils.dart->dart:html

Package not compatible with runtime native-aot

Because of the import of dart:html via the import chain package:angular_youtube_player/angular_youtube_player.dart->package:youtube_iframe_interop/youtube_iframe_interop.dart->package:youtube_iframe_interop/src/utils.dart->package:dart_browser_loader/dart_browser_loader.dart->package:dart_browser_loader/src/style.dart->package:dart_browser_loader/src/utils.dart->dart:html

Package not compatible with runtime native-jit

Because of the import of dart:html via the import chain package:angular_youtube_player/angular_youtube_player.dart->package:youtube_iframe_interop/youtube_iframe_interop.dart->package:youtube_iframe_interop/src/utils.dart->package:dart_browser_loader/dart_browser_loader.dart->package:dart_browser_loader/src/style.dart->package:dart_browser_loader/src/utils.dart->dart:html

Health suggestions

Format lib/angular_youtube_player.dart.

Run dartfmt to format lib/angular_youtube_player.dart.

Maintenance suggestions

Package is getting outdated. (-40 points)

The package was last published 73 weeks ago.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
angular ^5.0.0 5.3.1 6.0.0-alpha+1
youtube_iframe_interop ^0.1.0 0.1.0
Transitive dependencies
analyzer 0.35.4 0.39.11
angular_ast 0.5.9 0.5.11
angular_compiler 0.4.3 0.4.5
args 1.6.0
async 2.4.1
build_config 0.4.2
built_collection 4.3.2
built_value 7.1.0
charcode 1.1.3
checked_yaml 1.0.2
code_builder 3.3.0
collection 1.14.13
convert 2.1.1
crypto 2.1.5
csslib 0.14.6+1 0.16.1
dart_browser_loader 0.0.6+1
dart_style 1.2.4 1.3.6
fixnum 0.10.11
front_end 0.1.14 0.1.29
glob 1.2.0
intl 0.15.8 0.16.1
js 0.6.2
json_annotation 3.0.1
kernel 0.3.14 0.3.29
logging 0.11.4
matcher 0.12.8
meta 1.1.8 1.2.0
node_interop 1.1.1
node_io 1.1.1
package_config 1.9.3
path 1.7.0
pedantic 1.9.0 1.9.1
pub_semver 1.4.4
pubspec_parse 0.1.5
quiver 2.1.3
source_gen 0.9.4+4 0.9.5
source_span 1.7.0
stack_trace 1.9.5
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.2.0
watcher 0.9.7+15
yaml 2.2.1
Dev dependencies
build ^1.0.0 1.3.0
build_runner ^1.0.0
build_test >=0.10.0 <1.0.0
build_web_compilers >=0.4.0 <1.0.0
sass_builder ^2.0.1