angular_node_bind 0.2.0

  • Installing
  • Versions
  • 0

Angular Node Bind #

Utilities to allow Angular templates to use Node.bind().


NodeBindDirective lets you use Node.bind() in an Angular app. This means that you can bind to custom elements, including Polymer elements. The bindings are declared by expressions in attribute values surrounded by double-square-brackets, like so:

<input value="[[ name ]]">

This declares that the expression <code>name</code> should be bound to the value property of the element using Node.bind(). The advantages of using Node.bind are:

  • Node.bind() takes care of setting up the binding, including two-way bindings, eliminating the need for directives for every property for two-way bindings.
  • Custom elements that expose properties will be properly bound, again including two-way bindings. You can use the growing collection of custom element libraries in your Angular app.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  angular_node_bind: ^0.2.0

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:angular_node_bind/angular_node_bind.dart';
Version Uploaded Documentation Archive
0.2.0 May 15, 2014 Go to the documentation of angular_node_bind 0.2.0 Download angular_node_bind 0.2.0 archive
0.1.3 Feb 7, 2014 Go to the documentation of angular_node_bind 0.1.3 Download angular_node_bind 0.1.3 archive
0.1.2 Jan 24, 2014 Go to the documentation of angular_node_bind 0.1.2 Download angular_node_bind 0.1.2 archive
0.1.1 Dec 12, 2013 Go to the documentation of angular_node_bind 0.1.1 Download angular_node_bind 0.1.1 archive
0.1.0 Dec 12, 2013 Go to the documentation of angular_node_bind 0.1.0 Download angular_node_bind 0.1.0 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.