angular_color_picker 1.0.3

  • Readme
  • Changelog
  • Example
  • Installing
  • 48

angular_color_picker #

RGB, HSL color pickers for Angular Dart

1.0.3 #

  • Upgraded to latest lib_colors
  • awesome-color-picker accepts colors in string form

1.0.2 #

  • Support for named css colors

1.0.1 #

  • pub.dev fixes

1.0.0 #

  • Initial version, created by Stagehand

example/main.dart

import 'package:angular_color_picker/angular_color_picker.dart';
import 'package:lib_colors/lib_colors.dart';
import 'package:angular/angular.dart';
import 'main.template.dart' as ng;

@Component(
  selector: 'my-app',
  styles: [
    ':host {display: block; width: 250px; height: 100%; padding: 0px 5px; box-sizing: border-box;}',
  ],
  template:
      r'<awesome-color-picker [value]="color" (change)="color = $event"></awesome-color-picker>',
  directives: [AwesomeColorPicker],
)
class AppComponent {
  Color color = white;
}

void main() {
  runApp(ng.AppComponentNgFactory);
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  angular_color_picker: ^1.0.3

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:angular_color_picker/angular_color_picker.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
48
Learn more about scoring.

We analyzed this package on Oct 16, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.1
  • pana: 0.12.21

Platforms

Detected platforms: web

Primary library: package:angular_color_picker/angular_color_picker.dart with components: html, js.

Health issues and suggestions

Document public APIs. (-0.66 points)

86 out of 87 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Format lib/src/inputs/awesome_color_picker/awesome_color_picker.dart.

Run dartfmt to format lib/src/inputs/awesome_color_picker/awesome_color_picker.dart.

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (angular).

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.4.0 <3.0.0
angular ^5.3.0 5.3.1 6.0.0-alpha+1
lib_colors ^1.0.17 1.0.17
ng_bind ^1.0.2 1.0.2
Transitive dependencies
analyzer 0.35.4 0.38.5
angular_ast 0.5.9 0.5.11
angular_compiler 0.4.3 0.4.5
args 1.5.2
async 2.4.0
build 1.2.0
build_config 0.4.1+1
built_collection 4.2.2
built_value 6.7.1
charcode 1.1.2
checked_yaml 1.0.2
code_builder 3.2.0
collection 1.14.12
convert 2.1.1
crypto 2.1.3
csslib 0.14.6+1 0.16.1
dart_style 1.2.4 1.3.1
fixnum 0.10.9
front_end 0.1.14 0.1.27
glob 1.2.0
intl 0.15.8 0.16.0
js 0.6.1+1
json_annotation 3.0.0
kernel 0.3.14 0.3.27
logging 0.11.3+2
matcher 0.12.5
meta 1.1.7
node_interop 1.0.3
node_io 1.0.1+2
package_config 1.1.0
path 1.6.4
pub_semver 1.4.2
pubspec_parse 0.1.5
quiver 2.0.5
source_gen 0.9.4+4 0.9.4+5
source_span 1.5.5
stack_trace 1.9.3
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
watcher 0.9.7+12
yaml 2.2.0
Dev dependencies
angular_test ^2.3.0
build_runner ^1.5.0
build_test ^0.10.3
build_web_compilers ^2.1.0
pedantic ^1.7.0 1.8.0+1
test ^1.6.0