angel_toggle 1.0.0

toggle #

version 1.0.0 build status coverage: 100%

Allows you to substitute one service for another while testing. The primary use case is to test an application using in-memory services, although it may be using database services in the real world. This makes tests a bit faster, and also means that you don't have to write any boilerplate code to clean up a database between test runs.

Installation #

In your pubspec.yaml file:

  angel_toggle: ^1.0.0

Usage #

Within angel_toggle, there are two ways to specify that your application is running in "test mode":

  1. contains a key testMode, the value of which is true.
  2. Platform.script contains the string test (case-insensitive). This means you have to do no further configuration when running from the test/ directory.

This package exports a single plug-in:

toggleService #

If the application is running in test mode, then the second generator will be called. Otherwise, it defaults to the first generator.

If you really need to delay the mounting of the service, add this plug-in to app.justBeforeStart. If no second generator is provided, it will default to a MapService.

import 'package:angel_framework/angel_framework.dart';
import 'package:angel_toggle/angel_toggle.dart';

configureServer(Angel app) async {
  await app.configure(toggleService('/api/todos', () => new MongoService(...)));

Using the plug-in will print a message to the console, notifying you that a service has been toggled out.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  angel_toggle: ^1.0.0

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:angel_toggle/angel_toggle.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0