angel_diagnostics 1.0.2

diagnostics #

Support for logging and diagnostics within the Angel framework.

For accuracy, these plugins must be called after all other plugins are configured. The best way to ensure this would be to call it right before server startup:


Logging Requests #


This plug-in lets you log requests, responses and errors (optionally to a log file), and also displays how much time (in milliseconds) it took to handle a request.

It also injects a Logger singleton into your application.

Profiler #


This plug-in automatically prints profiling information on each request.


This middleware adds another label to the running profiler, if any. This makes it easy to detect application bottlenecks.

Both automatically turn themselves off in production mode. Use force to prevent this.

Usage #

See the examples.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  angel_diagnostics: ^1.0.2

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:angel_diagnostics/angel_diagnostics.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0