android_calendar_intents 0.0.5

  • Readme
  • Changelog
  • Installing
  • 40

android_calendar_intents #

Works only on Android

API #

CalendarIntents.showEventScreen(int eventId);
CalendarIntents.showAddEventScreen({
                  String title,
                  String description,
                  DateTime startTime,
                  DateTime endTime,
                  bool allDay,
                });

[0.0.1] - TODO: Add release date. #

  • TODO: Describe initial release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  android_calendar_intents: ^0.0.5

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:android_calendar_intents/android_calendar_intents.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
5
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
40
Overall:
Weighted score of the above. [more]
40
Learn more about scoring.

We analyzed this package on Jul 3, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13
  • Flutter: 1.17.5

Analysis suggestions

Package does not support Flutter platform ios

Because of import path [package:android_calendar_intents/android_calendar_intents.dart, package:android_intent/android_intent.dart] that declares support for platforms: android

Package does not support Flutter platform linux

Because of import path [package:android_calendar_intents/android_calendar_intents.dart, package:android_intent/android_intent.dart] that declares support for platforms: android

Package does not support Flutter platform macos

Because of import path [package:android_calendar_intents/android_calendar_intents.dart, package:android_intent/android_intent.dart] that declares support for platforms: android

Package does not support Flutter platform web

Because of import path [package:android_calendar_intents/android_calendar_intents.dart, package:android_intent/android_intent.dart] that declares support for platforms: android

Package does not support Flutter platform windows

Because of import path [package:android_calendar_intents/android_calendar_intents.dart, package:android_intent/android_intent.dart] that declares support for platforms: android

Package not compatible with SDK dart

because of import path [android_calendar_intents] that is in a package requiring null.

Health issues and suggestions

Document public APIs. (-1 points)

5 out of 5 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Format lib/android_calendar_intents.dart.

Run flutter format to format lib/android_calendar_intents.dart.

Maintenance issues and suggestions

Use constrained dependencies. (-20 points)

The pubspec.yaml contains 1 dependency without version constraints. Specify version ranges for the following dependencies: android_intent.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and android_calendar_intents.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.3.0 <3.0.0
android_intent any 0.3.7+2
flutter 0.0.0
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8
platform 2.2.1
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8
Dev dependencies
flutter_test