amaze_button 0.0.3

amaze_button #

An amazing flutter package for amazing future buttons.

0.0.1 #

  • Initial release.

0.0.2 #

  • Support for Dart version 2.

0.0.3 #

  • Updated package description.

example/main.dart

import 'dart:async';

import 'package:flutter/material.dart';
import 'package:amaze_button/amaze_button.dart';

void main() => runApp(new MyApp());

class MyApp extends StatelessWidget {
  @override
  Widget build(BuildContext context) {
    return new MaterialApp(
      title: 'Flutter Demo',
      theme: new ThemeData(
        primarySwatch: Colors.blue,
      ),
      home: new MyHomePage(),
    );
  }
}

class MyHomePage extends StatelessWidget {
  @override
  Widget build(BuildContext context) {
    return new Scaffold(
      appBar: new AppBar(
        title: new Text('Home Page'),
      ),
      body: new ListView(
        children: <Widget>[
          new FutureAmazeButton(
            child: new Container(
              child: new Text(
                'Some Text',
                style: new TextStyle(fontSize: 20.0),
              ),
              padding: new EdgeInsets.all(10.0),
              decoration: new BoxDecoration(
                  border: new Border.all(
                      color: Colors.black,
                      width: 1.0,
                      style: BorderStyle.solid),
                  borderRadius:
                      new BorderRadius.all(new Radius.circular(10.0))),
            ),
            futureCall: () {
              return new Future.delayed(Duration(seconds: 2));
            },
          ),
        ],
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  amaze_button: ^0.0.3

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:amaze_button/amaze_button.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
48
Learn more about scoring.

We analyzed this package on Aug 22, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.4.0
  • pana: 0.12.19
  • Flutter: 1.7.8+hotfix.4

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance suggestions

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0 <3.0.0
flutter 0.0.0
test ^1.3.0 1.6.8
Transitive dependencies
analyzer 0.38.1
args 1.5.2
async 2.3.0
boolean_selector 1.0.5
charcode 1.1.2
collection 1.14.11 1.14.12
convert 2.1.1
crypto 2.1.2
csslib 0.16.1
front_end 0.1.23
glob 1.1.7
html 0.14.0+2
http 0.12.0+2
http_multi_server 2.1.0
http_parser 3.1.3
io 0.3.3
js 0.6.1+1
kernel 0.3.23
matcher 0.12.5
meta 1.1.6 1.1.7
mime 0.9.6+3
multi_server_socket 1.0.2
node_preamble 1.4.6
package_config 1.1.0
package_resolver 1.0.10
path 1.6.4
pedantic 1.8.0+1
pool 1.4.0
pub_semver 1.4.2
shelf 0.7.5
shelf_packages_handler 1.0.4
shelf_static 0.2.8
shelf_web_socket 0.2.3
sky_engine 0.0.99
source_map_stack_trace 1.1.5
source_maps 0.10.8
source_span 1.5.5
stack_trace 1.9.3
stream_channel 2.0.0
string_scanner 1.0.5
term_glyph 1.1.0
test_api 0.2.7
test_core 0.2.9
typed_data 1.1.6
vector_math 2.0.8
vm_service 1.1.1
watcher 0.9.7+12
web_socket_channel 1.0.15
yaml 2.1.16
Dev dependencies
flutter_test