aluqard 0.0.2

  • Readme
  • Changelog
  • Example
  • Installing
  • 44

Aluqard - a Hooks-based client for GraphQL #

Aluqard is a library for Flutter Hooks-based apps to use GraphQL, heavily based on Draqula.

License #

Aluqard is free to use for non-commercial projects, and is free to use for a 30-day trial in commercial software. If you would like to use this library in a commercial product, please contact the author at anais@anaisbetts.org to negotiate a license.

[0.0.2] - 9/9/2019

  • Initial Release

example/README.md

Example app #

This demo app makes a few example calls to GraphQL APIs via Aluqard.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  aluqard: ^0.0.2

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:aluqard/aluqard.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
44
Learn more about scoring.

We analyzed this package on Nov 19, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.0
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.6

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health issues and suggestions

Document public APIs. (-1 points)

13 out of 13 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Maintenance issues and suggestions

Support latest dependencies. (-20 points)

The version constraint in pubspec.yaml does not support the latest published versions for 2 dependencies (dio, flutter_hooks).

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
dio ^2.1.16 2.2.2 3.0.5
flutter 0.0.0
flutter_hooks ^0.6.0 0.6.1 0.7.0
graphql ^2.1.0 2.1.0 2.1.1-beta.3
graphql_flutter ^2.1.0 2.1.0 2.1.1-beta.3
Transitive dependencies
async 2.4.0
charcode 1.1.2
collection 1.14.11 1.14.12
convert 2.1.1
cookie_jar 1.0.1
crypto 2.1.3
graphql_parser 1.1.4
http 0.12.0+2
http_parser 3.1.3
meta 1.1.7 1.1.8
mime 0.9.6+3
path 1.6.4
path_provider 1.4.2
pedantic 1.8.0+1
platform 2.2.1
rxdart 0.22.6
sky_engine 0.0.99
source_span 1.5.5
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
uuid_enhanced 3.0.2
vector_math 2.0.8
websocket 0.0.5
Dev dependencies
flutter_test