alrasasi_animated_multi_select 0.0.1

  • Readme
  • Changelog
  • Example
  • Installing
  • 46

Alrasasi Multi Selection Animated Widget #

Build Status

Features #

Get your horizantal smooth multi-select widget.

  • Change the color as you want
  • Change the size
  • Put it anywhere

Image description

Installation #

You should ensure that you add the alrasasi_animated_multi_select as a dependency in your flutter project.


dependencies:
  alrasasi_animated_multi_select: ^0.0.1

You should then run flutter packages get in your terminal so as to get the package.

Usage #

For production environments...

            MultiSelectChip(
                color: Colors.deepPurpleAccent,
                raduis: 100,
                mainList: this.mainList,
                onSelectionChanged: (selectedList) {
                  setState(() {
                    selectedList = selectedList;
                  });
                },
                initialSelectionList: selectedList,
                textStyle: TextStyle(color: Colors.purple, )
            ),

Documentation #

MultiSelectChip class #

PluginREADME
colorThe color of the widget and its border
raduisThe height of the circle
mainListMain list the user select from
onSelectionChangedA function to react to selection actions
initialSelectionListInitial list part from the main list
textStyleStyling the text inside the widget

"# animated_multi_selection"

[0.0.1] - TODO: Add release date.

  • TODO: Describe initial release.

example/example.dart

import 'package:flutter/material.dart';
import 'package:alrasasi_animated_multi_select/alrasasi_animated_multi_select.dart';

void main() => runApp(MyApp());

class MyApp extends StatelessWidget {
  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      title: 'Flutter Demo',
      theme: ThemeData(
        primarySwatch: Colors.blue,
      ),
      home: MyHomePage(title: 'Flutter Demo Home Page'),
    );
  }
}

class MyHomePage extends StatefulWidget {
  MyHomePage({Key key, this.title}) : super(key: key);

  final String title;

  @override
  _MyHomePageState createState() => _MyHomePageState();
}

class _MyHomePageState extends State<MyHomePage> {
  List<String> mainList = [
    "Not relevant",
    "Illegal",
    "Spam",
    "Offensive",
    "Uncivil",
    "select",
    'ont'
  ];

  List<String> selectedList = ["Not relevant", "Illegal", "Spam", 'ont'];

  @override
  Widget build(BuildContext context) {
    return Scaffold(
      appBar: AppBar(
        title: Text(widget.title),
      ),
      body: Center(
        child: Column(
          mainAxisAlignment: MainAxisAlignment.center,
          crossAxisAlignment: CrossAxisAlignment.center,
          children: <Widget>[
            Text(selectedList.join(" , ")),
            //
            MultiSelectChip(
                color: Colors.deepPurpleAccent,
                raduis: 100,
                mainList: this.mainList,
                onSelectionChanged: (selectedList) {
                  setState(() {
                    selectedList = selectedList;
                  });
                },
                initialSelectionList: selectedList,
                textStyle: TextStyle(color: Colors.purple, )
            ),

          ],
        ),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  alrasasi_animated_multi_select: ^0.0.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:alrasasi_animated_multi_select/alrasasi_animated_multi_select.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
3
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
46
Learn more about scoring.

We analyzed this package on Oct 16, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.1
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.4

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Format lib/alrasasi_animated_multi_select.dart.

Run flutter format to format lib/alrasasi_animated_multi_select.dart.

Format lib/circle_button.dart.

Run flutter format to format lib/circle_button.dart.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test