aloha 3.0.2

  • Readme
  • Changelog
  • Example
  • Installing
  • 50

aloha #

Bindings for the Aloha HTML5 editor.

This version currently implements nearly all the core Aloha Events and API and the editables API. Repository and registry API's are not yet implemented.

Please see the usage.md document in the doc directory for further usage details.

3.0.2 #

Linter + pana updates

3.0.1 #

Linter updates

3.0.0 #

Updates for Dart 2.0

2.0.1 #

Updated for use with Dart 1.6 Issues 1 and 2 incorporated. Note: Aloha now uses dart:js, not package:js, no API changes

2.0.0 #

Updated for Dart 1.0 Aloha CDN now uses latest branch Note; still using js 0.0.26, not upgraded this at this time

example/example.dart

/*
 * Package : aloha
 * Author : S. Hamblett <steve.hamblett@linux.com>
 * Date   : 05/09/2018
 * Copyright :  S.Hamblett@OSCF
 */

/// Examples of usage to be found in the test suite
int main() => 0;

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  aloha: ^3.0.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:aloha/aloha.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
50
Learn more about scoring.

We analyzed this package on Jul 7, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13

Analysis suggestions

Package not compatible with runtime flutter-native on android

Because of the import of dart:js via the import chain package:aloha/aloha.dartdart:js

Package not compatible with runtime flutter-native on ios

Because of the import of dart:js via the import chain package:aloha/aloha.dartdart:js

Package not compatible with runtime flutter-native on linux

Because of the import of dart:js via the import chain package:aloha/aloha.dartdart:js

Package not compatible with runtime flutter-native on macos

Because of the import of dart:js via the import chain package:aloha/aloha.dartdart:js

Package not compatible with runtime flutter-native on windows

Because of the import of dart:js via the import chain package:aloha/aloha.dartdart:js

Package not compatible with runtime native-aot

Because of the import of dart:js via the import chain package:aloha/aloha.dartdart:js

Package not compatible with runtime native-jit

Because of the import of dart:js via the import chain package:aloha/aloha.dartdart:js

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
Dev dependencies
build_runner ^1.8.0
build_test ^0.10.12+1
build_web_compilers ^2.8.0
pana ^0.13.5
pedantic ^1.9.0
test ^1.14.2