aliyun_video 0.0.3

  • Readme
  • Changelog
  • Example
  • Installing
  • 57

阿里短视频SDK Flutter版本 #

页面使用阿里提供的Demo页面加以修改,目前没有特效,只有拍照和拍视频功能

去除 滤镜 GIF 美颜

添加拍照



0.0.1 #

  • TODO: init

0.0.2 #

  • TODO: 增加拍摄或视频参数

0.0.3 #

  • TODO: 美颜功能 0-5

example/README.md

aliyun_video_example #

Demonstrates how to use the aliyun_video plugin.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  aliyun_video: ^0.0.3

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:aliyun_video/aliyun_video.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
19
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
57
Learn more about scoring.

We analyzed this package on Feb 27, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.5
  • Flutter: 1.12.13+hotfix.8

Health issues and suggestions

Document public APIs. (-0.14 points)

33 out of 34 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Fix lib/aliyun_video.dart. (-1 points)

Analysis of lib/aliyun_video.dart reported 2 hints:

line 3 col 8: Unused import: 'package:flutter/cupertino.dart'.

line 5 col 8: Unused import: 'dart:convert'.

Maintenance suggestions

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test