alipay_me 1.0.0

  • Readme
  • Changelog
  • Example
  • Installing
  • 73

alipay_me #

pub package GitHub GitHub stars

Alipay plug-in. Support payment and authorized login. Support Android and iOS. Android supports local computational signatures.

Usage #

To use this plugin, add alipay_me as a dependency in your pubspec.yaml file.

ROADMAP #

  • [x] 发起支付
  • [x] 授权登录
  • [x] 本地计算签名(仅Android)
  • [x] 沙盒模式(仅Android)

Supported Platforms

  • Android
  • IOS

Examples #

  • Examples App - Demonstrates how to use the alipay_me plugin.
import 'package:alipay_me/alipay_me.dart';

  // 初始化
  initAlipay() async {
    final String tid = "tid_${DateTime.now().millisecondsSinceEpoch}";
    await AlipayMe.init(
        appId: "2019010362782013",
        pid: "2088012716890635",
        rsa2Private: RSAPrivate,
        targetId: tid
    );
  }
  
  // 发起支付
  var o = await AlipayMe.pay(apyInfo,
      urlScheme: "alisdkdemo",  // 这里的URL Schemes中输入的alisdkdemo,为测试demo,实际商户的app中要填写独立的scheme
      isSandbox: _isSandbox,
   );

  //授权申请
  await AlipayMe.auth(
        urlScheme: "alisdkdemo", // 这里的URL Schemes中输入的alisdkdemo,为测试demo,实际商户的app中要填写独立的scheme
        isSandbox: _isSandbox,
        authInfo: data,
      );
  

License MIT #

Copyright (c) 2019

1.0.0 #

  • TODO: Describe initial release.

example/README.md

alipay_me_example #

Demonstrates how to use the alipay_me plugin.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  alipay_me: ^1.0.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:alipay_me/alipay_me.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
47
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
73
Learn more about scoring.

We analyzed this package on Nov 11, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.0
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.6

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Format lib/alipay_me.dart.

Run flutter format to format lib/alipay_me.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8