alert_controller 0.0.5

  • Readme
  • Changelog
  • Example
  • Installing
  • 63

alert_controller #

alert_controller 是一个展示iOS系统的AlertController的插件,目前只是适配了ios 使用原生的语法形式调用ios系统弹框,支持actionSheet和alert

Installation #

Add dependency to pubspec.yaml

dependencies:
  ...
  alert_controller: ^0.0.5

Run in your terminal

flutter packages get

Example #

      Widget build(BuildContext context) {
    return MaterialApp(
      home: Scaffold(
        appBar: AppBar(
          title: const Text('Plugin example app'),
        ),
        body: Center(
          child: new InkWell(
            child: new Text("点击弹框"),
            onTap: (){
                var alertVc = AlertController(title: "测试弹框",message: "这是一个弹框",preferredStyle: AlertStyle.actionSheet);
                var action1 = AlertAction(title: "举报",style: AlertActionStyle.cancel,handler: (action){
                    print(action.title);
                });
                var action0 = AlertAction(title: "111",style: AlertActionStyle.normal,handler: (action){
                    print(action.title);
                });
                var action2 = AlertAction(title: "222",style: AlertActionStyle.normal,handler: (action){
                    print(action.title);
                });
                var action3 = AlertAction(title: "333",style: AlertActionStyle.normal,handler: (action){
                    print(action.title);
                });
                var action4 = AlertAction(title: "444",style: AlertActionStyle.normal,handler: (action){
                    print(action.title);
                });
                alertVc.addAction(action0);
                alertVc.addAction(action1);
                alertVc.addAction(action2);
                alertVc.addAction(action4);
                alertVc.addAction(action1);
                alertVc.show();
            },
          )
        ),
      ),
    );
  }

0.0.5 #

  • 更新了说明文档,代码优化保持稳定

0.0.4 #

  • fix ios13会崩溃的问题,加了ipad设备判断

example/lib/main.dart

import 'package:flutter/material.dart';
import 'dart:async';

import 'package:flutter/services.dart';
import 'package:alert_controller/alert_controller.dart';

void main() => runApp(MyApp());

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => _MyAppState();
}

class _MyAppState extends State<MyApp> {
  String _platformVersion = 'Unknown';

  @override
  void initState() {
    super.initState();
  }


  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      home: Scaffold(
        appBar: AppBar(
          title: const Text('Plugin example app'),
        ),
        body: Center(
          child: new InkWell(
            child: new Text("点击弹框"),
            onTap: (){
                var alertVc = AlertController(title: "测试弹框",message: "这是一个弹框",preferredStyle: AlertStyle.actionSheet);
                var action1 = AlertAction(title: "举报",style: AlertActionStyle.cancel,handler: (action){
                    print(action.title);
                });
                var action0 = AlertAction(title: "111",style: AlertActionStyle.normal,handler: (action){
                    print(action.title);
                });
                var action2 = AlertAction(title: "222",style: AlertActionStyle.normal,handler: (action){
                    print(action.title);
                });
                var action3 = AlertAction(title: "333",style: AlertActionStyle.normal,handler: (action){
                    print(action.title);
                });
                var action4 = AlertAction(title: "444",style: AlertActionStyle.normal,handler: (action){
                    print(action.title);
                });
                alertVc.addAction(action0);
                alertVc.addAction(action1);
                alertVc.addAction(action2);
                alertVc.addAction(action4);
                alertVc.addAction(action1);
                alertVc.show();
            },
          )
        ),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  alert_controller: ^0.0.5

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:alert_controller/alert_controller.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
46
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
50
Overall:
Weighted score of the above. [more]
63
Learn more about scoring.

We analyzed this package on Apr 7, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.6
  • Flutter: 1.12.13+hotfix.8

Health suggestions

Format lib/alert_controller.dart.

Run flutter format to format lib/alert_controller.dart.

Maintenance issues and suggestions

The description contains too many non-ASCII characters. (-20 points)

The site uses English as its primary language. The value of the description field in your package's pubspec.yaml field should primarily contain characters used in English.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test