ajlocation 1.0.7

  • Readme
  • Changelog
  • Example
  • Installing
  • 69

ajlocation #

Plugin to allow you get users location for iOS and Android. You can also get the location updates in background mode. Allows you to check status of currently selected authorization.

How to use #

Getting Started #

This project is a starting point for a Flutter plug-in package, a specialized package that includes platform-specific implementation code for Android and/or iOS.

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

1.0.7 #

  • iOS requestAuthorization fix.

1.0.6 #

  • Android requestAuthorization fixed.

1.0.5 #

  • AndroidX support.

1.0.4 #

  • Android minimum SDK version is now 21.

1.0.3 #

  • Fixed documentation.

1.0.2 #

  • Added Android support
  • Fixes for iOS
  • Fixes for Android
  • Added getCurrentLocation which will return current location but only once.

1.0.1 #

  • Changed minimum version of iOS to 9.0.

1.0.0 #

  • Support for iOS added.

example/README.md

ajlocation_example #

Demonstrates how to use the ajlocation plugin.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  ajlocation: ^1.0.7

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:ajlocation/ajlocation.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
40
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
94
Overall:
Weighted score of the above. [more]
69
Learn more about scoring.

We analyzed this package on Oct 9, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.1
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.4

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Format lib/ajlocation.dart.

Run flutter format to format lib/ajlocation.dart.

Maintenance suggestions

Homepage URL is insecure. (-5 points)

Update the homepage field and use a secure (https) URL.

The description is too long. (-1 points)

Search engines display only the first part of the description. Try to keep the value of the description field in your package's pubspec.yaml file between 60 and 180 characters.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test