ago 0.0.4

  • Readme
  • Changelog
  • Example
  • Installing
  • 58

ago #

A new Flutter package project for displaying fuzzy time.

Install #

Add dependency to your pubspec.yaml:

ago: any

Get the packages:

flutter packages get

Usage #

import 'package:ago/ago.dart';
var justNow = 3));
ago(justNow); // 刚刚

Test #

Run flutter test in the terminal.

Publish #

  • Remember to update version.
  • Run pub publish --dry-run.
  • If no warnings or erros,remove --dry-run and execute pub publish.

Getting Started #

For help getting started with Flutter, view our online documentation.

For help on editing package code, view the documentation.

[0.0.1] - 2018-12-09

  • Release v0.0.1 with the first api ago(DateTime date, DateTime comparedWith).

[0.0.2] - 2018-12-11

  • Update docs: add usage.


import '../lib/ago.dart';

void main() {
  var justNow = 3));
  print(ago(justNow)); // 刚刚

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  ago: ^0.0.4

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:ago/ago.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Jan 27, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.4
  • Flutter: 1.12.13+hotfix.5

Health issues and suggestions

Document public APIs. (-1 points)

2 out of 2 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Format lib/ago.dart.

Run flutter format to format lib/ago.dart.

Maintenance suggestions

Package is getting outdated. (-12.88 points)

The package was last published 58 weeks ago.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies