advanced_datatable 0.0.8 icon indicating copy to clipboard operation
advanced_datatable: ^0.0.8 copied to clipboard

An addtion to the Flutter PaginatedDataTable allowing pagination also for the datasource aka server side datatables

[0.0.2] - 04/30/2021 #

  • Server side data table with paging support
  • Allowing the same changes as the build in PaginatedDataTable

[0.0.3] - 04/31/2021 #

  • Auto reload page in case column sorting is changed

[0.0.3+1] - 05/02/2021 #

  • Updated readme to include the live example

[0.0.3+2] - 06/21/2021 #

  • Allow local reload if possible
  • Updated example to contain selection of rows
  • Selection of rows no longer trigger a call to the remote data source

[0.0.4] - 07/18/2021 #

  • Trigger a remote reload if you want it
  • Updated related packages
  • New example with filter

[0.0.5] - 07/18/2021 #

  • Include total and total filtered rows if provided in footer text
  • Allow custom footer text for rows

[0.0.6] - 08/14/2021 #

  • Updated example to contain usage for server side filter
  • Allow the source to reset the first view index, can be used to go back to page 1
  • Updated test cases to support new functions

[0.0.7] - 10/24/2021 #

  • BREAKING CHANGES, see the readme
  • Including Flutter Lint
  • Customer table footer support, render your complete own footer if you wish too
  • Updated example to support horizontal scroll with flutter 2.5.X
  • New default loading, keep table sceleton and show a centered spinner

[0.0.7+hotfix] - 10/24/2021 #

  • Table now takes full width again

[0.0.8] - 06/04/2022 #

  • Allow to set alignment for default footer
  • Show horizontal scrollbar for table content
  • Allow to set thumbVisibility for horizontal scrollbar
56
likes
140
pub points
91%
popularity

Publisher

verified publisher icondevowl.de

An addtion to the Flutter PaginatedDataTable allowing pagination also for the datasource aka server side datatables

Homepage

Documentation

API reference

License

Icon for licenses.BSD-3-Clause (LICENSE)

Dependencies

flutter

More

Packages that depend on advanced_datatable