adcolony 1.0.0

  • Readme
  • Changelog
  • Example
  • Installing
  • 78

Flutter AdColony #

Note: Currently only Android platform is supported.

Note: AndroidX is required.

Getting Started #

1. Initialization #

Call Adcolony.initialize(); during app initialization.

AdColony.initialize(appid: 'your_app_id', zoneid: ['your_zones_ids'], consent: true or flase);

2. Request Interstitial Ad and Rewarded Video Ad #

AdColony.requestInterstitial(zoneId: zoneId, listener: (AdColonyEvent event) {});

3. Show Ad in listener #

if (AdColonyEvent.onRequestFilled == event)
    AdColony.showAd();

4. Show Ad Banner #

AdColonyBanner('vz09f26f8ad3c340c484', BannerSizes.BANNER, (BannerEvent event) {}),

5. ProGuard Configuration #

# For communication with AdColony's WebView
-keepclassmembers class * { 
    @android.webkit.JavascriptInterface <methods>; 
}
# For removing warnings due to lack of Multi-Window support
-dontwarn android.app.Activity

Events #

EventDescription
OnRequestFilledCalled in response to an ad request when the request has been successfully filled.
OnRequestNotFilledCalled in response to an ad request when the request failed to fill.
OnRewardCalled when the rewarded video ends successfully.

Future Work #

Implement for iOS platform.

0.0.1 #

  • TODO: Describe initial release.

1.0.0 #

  • Upgrade SDK AdColony
  • Include Banners

example/README.md

Flutter AdColony #

Note: Currently only Android platform is supported.

Getting Started #

1. Initialization #

Call Adcolony.initialize(); during app initialization.

Adcolony.initialize(appid: 'your_app_id', zoneid: ['your_zones_ids']);

2. Request Interstitial Ad and Rewarded Video Ad #

Adcolony.requestInterstitial(zoneid: 'your_zone_interstitial_id');

3. Show Ad #

Adcolony.onRequestFilled = () {
    Adcolony.showAd();
};

4. ProGuard Configuration #

# For communication with AdColony's WebView
-keepclassmembers class * { 
    @android.webkit.JavascriptInterface <methods>; 
}
# For removing warnings due to lack of Multi-Window support
-dontwarn android.app.Activity

Events #

EventDescription
OnRequestFilledCalled in response to an ad request when the request has been successfully filled.
OnRequestNotFilledCalled in response to an ad request when the request failed to fill.
OnOpenedCalled when the interstitial ad opens.
OnExpiringCalled when an intersitial expires and is no longer valid for playback.
OnRewardcalled when the rewarded video ends successfully.

Future Work #

Implement for iOS platform.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  adcolony: ^1.0.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:adcolony/AdColony.dart';
import 'package:adcolony/AdColonyBanner.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
55
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
78
Learn more about scoring.

We analyzed this package on Oct 18, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.1
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.4

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health issues and suggestions

Document public APIs. (-0.03 points)

29 out of 30 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Format lib/AdColony.dart.

Run flutter format to format lib/AdColony.dart.

Format lib/AdColonyBanner.dart.

Run flutter format to format lib/AdColonyBanner.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test