acs_nfc 1.0.2

acs_nfc #

A new flutter plugin project.

https://pub.dev/packages/acs_nfc/

Getting Started #

  • Import the library: import 'package:acs_nfc/acs_nfc.dart';

  • Open connection the connection

    await AcsNfc.openConnection(ip: '192.168.137.1', port: '8001');

  • Listen to connection Status

    AcsNfc.connectionStatusStream.receiveBroadcastStream().listen(nfcConnectionStatus);

  • List to Nfc data

    AcsNfc.nfcDataStream.receiveBroadcastStream().listen(nfcData);

  • Data format is:

    {"nfcBytes":"","nfcId":""}

1.0.2 #

  • Fix Bugs.

1.0.1 #

  • Added send Android Serial Number function to IOT device.

1.0.0 #

  • Update ReadMe.

0.0.1 #

  • Initial release.

example/README.md

acs_nfc_example #

Demonstrates how to use the acs_nfc plugin.

Getting Started #

  • Import the library: import 'package:acs_nfc/acs_nfc.dart';

  • Open connection the connection

    await AcsNfc.openConnection(ip: '192.168.137.1', port: '8001');

  • Listen to connection Status

    AcsNfc.connectionStatusStream.receiveBroadcastStream().listen(nfcConnectionStatus);

  • List to Nfc data

    AcsNfc.nfcDataStream.receiveBroadcastStream().listen(nfcData);

  • Data format is:

    {"nfcBytes":"","nfcId":""}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  acs_nfc: ^1.0.2

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:acs_nfc/acs_nfc.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
31
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
62
Learn more about scoring.

We analyzed this package on Aug 21, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.4.0
  • pana: 0.12.19
  • Flutter: 1.7.8+hotfix.4

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Format lib/generated/i18n.dart.

Run flutter format to format lib/generated/i18n.dart.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.4.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test