Flutter_Nectar 0.1.0

Nectar #

Flutter widget to fade the display of an network image. You can configure the 'waiting' child and the fading duration.

Usage #

new NectarImage.loadingScreen(
        'https://camo.githubusercontent.com/cc78649bf43a7295cbab36eb7b5c7fe05b0f2bdb/68747470733a2f2f666c75747465722e696f2f696d616765732f666c75747465722d6d61726b2d7371756172652d3130302e706e67',
        duration: 4000, // optional
        backgroundColor: Colors.white, // optional, define default waiting background
        foregroundColor: Colors.blue, // optional, define default waiting foreground
        // optional, replace waiting with your Widget like your animation or image.
        /*waiting: new Icon(
            Icons.person,
            size: 18.0,
            color: Colors.red
        )*/
      ),

Getting Started #

Find more Flutter Resources =>Awesome Flutter

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  Flutter_Nectar: ^0.1.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:Flutter_Nectar/main.dart';
import 'package:Flutter_Nectar/solido.nectar.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.