GetRouterComputeBetaResult class
Result data returned by getRouter.
Constructors
-
GetRouterComputeBetaResult({required RouterBgpResponseComputeBeta bgp, required List<
RouterBgpPeerResponseComputeBeta> bgpPeers, required String creationTimestamp, required String description, required bool encryptedInterconnectRouter, required List<RouterInterfaceResponseComputeBeta> interfaces, required String kind, required List<RouterMd5AuthenticationKeyResponseComputeBeta> md5AuthenticationKeys, required String name, required List<RouterNatResponseComputeBeta> nats, required String network, required String region, required String selfLink}) -
Creates a new GetRouterComputeBetaResult.
bgpBGP information specific to this router.bgpPeersBGP information that must be configured into the routing stack to establish BGP peering. This information must specify the peer ASN and either the interface name, IP address, or peer IP address. Please refer to RFC4273.creationTimestampCreation timestamp in RFC3339 text format.descriptionAn optional description of this resource. Provide this property when you create the resource.encryptedInterconnectRouterIndicates if a router is dedicated for use with encrypted VLAN attachments (interconnectAttachments).interfacesRouter interfaces. To create a BGP peer that uses a router interface, the interface must have one of the following fields specified: - linkedVpnTunnel - linkedInterconnectAttachment - subnetwork You can create a router interface without any of these fields specified. However, you cannot create a BGP peer that uses that interface.kindType of resource. Always compute#router for routers.md5AuthenticationKeysKeys used for MD5 authentication.nameName of the resource. Provided by the client when the resource is created. The name must be 1-63 characters long, and comply with RFC1035. Specifically, the name must be 1-63 characters long and match the regular expression[a-z]([-a-z0-9]*[a-z0-9])?which means the first character must be a lowercase letter, and all following characters must be a dash, lowercase letter, or digit, except the last character, which cannot be a dash.natsA list of NAT services created in this router.networkURI of the network to which this router belongs.regionURI of the region where the router resides. You must specify this field as part of the HTTP request URL. It is not settable as a field in the request body.selfLinkServer-defined URL for the resource.const -
GetRouterComputeBetaResult.fromMap(Map<
String, dynamic> map) -
factory
Properties
- bgp → RouterBgpResponseComputeBeta
-
BGP information specific to this router.
final
-
bgpPeers
→ List<
RouterBgpPeerResponseComputeBeta> -
BGP information that must be configured into the routing stack to establish BGP peering. This information must specify the peer ASN and either the interface name, IP address, or peer IP address. Please refer to RFC4273.
final
- creationTimestamp → String
-
Creation timestamp in RFC3339 text format.
final
- description → String
-
An optional description of this resource. Provide this property when you create the resource.
final
- encryptedInterconnectRouter → bool
-
Indicates if a router is dedicated for use with encrypted VLAN attachments (interconnectAttachments).
final
- hashCode → int
-
The hash code for this object.
no setterinherited
-
interfaces
→ List<
RouterInterfaceResponseComputeBeta> -
Router interfaces. To create a BGP peer that uses a router interface, the interface must have one of the following fields specified: - linkedVpnTunnel - linkedInterconnectAttachment - subnetwork You can create a router interface without any of these fields specified. However, you cannot create a BGP peer that uses that interface.
final
- kind → String
-
Type of resource. Always compute#router for routers.
final
-
md5AuthenticationKeys
→ List<
RouterMd5AuthenticationKeyResponseComputeBeta> -
Keys used for MD5 authentication.
final
- name → String
-
Name of the resource. Provided by the client when the resource is created. The name must be 1-63 characters long, and comply with RFC1035. Specifically, the name must be 1-63 characters long and match the regular expression
[a-z]([-a-z0-9]*[a-z0-9])?which means the first character must be a lowercase letter, and all following characters must be a dash, lowercase letter, or digit, except the last character, which cannot be a dash.final -
nats
→ List<
RouterNatResponseComputeBeta> -
A list of NAT services created in this router.
final
- network → String
-
URI of the network to which this router belongs.
final
- region → String
-
URI of the region where the router resides. You must specify this field as part of the HTTP request URL. It is not settable as a field in the request body.
final
- runtimeType → Type
-
A representation of the runtime type of the object.
no setterinherited
- selfLink → String
-
Server-defined URL for the resource.
final
Methods
-
noSuchMethod(
Invocation invocation) → dynamic -
Invoked when a nonexistent method or property is accessed.
inherited
-
toMap(
) → Map< String, dynamic> -
toString(
) → String -
A string representation of this object.
inherited
Operators
-
operator ==(
Object other) → bool -
The equality operator.
inherited