GetRouterComputeBetaResult constructor

const GetRouterComputeBetaResult({
  1. required RouterBgpResponseComputeBeta bgp,
  2. required List<RouterBgpPeerResponseComputeBeta> bgpPeers,
  3. required String creationTimestamp,
  4. required String description,
  5. required bool encryptedInterconnectRouter,
  6. required List<RouterInterfaceResponseComputeBeta> interfaces,
  7. required String kind,
  8. required List<RouterMd5AuthenticationKeyResponseComputeBeta> md5AuthenticationKeys,
  9. required String name,
  10. required List<RouterNatResponseComputeBeta> nats,
  11. required String network,
  12. required String region,
  13. required String selfLink,
})

Creates a new GetRouterComputeBetaResult. bgp BGP information specific to this router. bgpPeers BGP information that must be configured into the routing stack to establish BGP peering. This information must specify the peer ASN and either the interface name, IP address, or peer IP address. Please refer to RFC4273. creationTimestamp Creation timestamp in RFC3339 text format. description An optional description of this resource. Provide this property when you create the resource. encryptedInterconnectRouter Indicates if a router is dedicated for use with encrypted VLAN attachments (interconnectAttachments). interfaces Router interfaces. To create a BGP peer that uses a router interface, the interface must have one of the following fields specified: - linkedVpnTunnel - linkedInterconnectAttachment - subnetwork You can create a router interface without any of these fields specified. However, you cannot create a BGP peer that uses that interface. kind Type of resource. Always compute#router for routers. md5AuthenticationKeys Keys used for MD5 authentication. name Name of the resource. Provided by the client when the resource is created. The name must be 1-63 characters long, and comply with RFC1035. Specifically, the name must be 1-63 characters long and match the regular expression [a-z]([-a-z0-9]*[a-z0-9])? which means the first character must be a lowercase letter, and all following characters must be a dash, lowercase letter, or digit, except the last character, which cannot be a dash. nats A list of NAT services created in this router. network URI of the network to which this router belongs. region URI of the region where the router resides. You must specify this field as part of the HTTP request URL. It is not settable as a field in the request body. selfLink Server-defined URL for the resource.

Implementation

const GetRouterComputeBetaResult({
  required this.bgp,
  required this.bgpPeers,
  required this.creationTimestamp,
  required this.description,
  required this.encryptedInterconnectRouter,
  required this.interfaces,
  required this.kind,
  required this.md5AuthenticationKeys,
  required this.name,
  required this.nats,
  required this.network,
  required this.region,
  required this.selfLink,
});