GetHttpHealthCheckComputeBetaResult class
Result data returned by getHttpHealthCheck.
Constructors
- GetHttpHealthCheckComputeBetaResult({required int checkIntervalSec, required String creationTimestamp, required String description, required int healthyThreshold, required String host, required String kind, required String name, required int port, required String requestPath, required String selfLink, required int timeoutSec, required int unhealthyThreshold})
-
Creates a new GetHttpHealthCheckComputeBetaResult.
checkIntervalSecHow often (in seconds) to send a health check. The default value is 5 seconds.creationTimestampCreation timestamp in RFC3339 text format.descriptionAn optional description of this resource. Provide this property when you create the resource.healthyThresholdA so-far unhealthy instance will be marked healthy after this many consecutive successes. The default value is 2.hostThe value of the host header in the HTTP health check request. If left empty (default value), the public IP on behalf of which this health check is performed will be used.kindType of the resource. Always compute#httpHealthCheck for HTTP health checks.nameName of the resource. Provided by the client when the resource is created. The name must be 1-63 characters long, and comply with RFC1035. Specifically, the name must be 1-63 characters long and match the regular expression[a-z]([-a-z0-9]*[a-z0-9])?which means the first character must be a lowercase letter, and all following characters must be a dash, lowercase letter, or digit, except the last character, which cannot be a dash.portThe TCP port number for the HTTP health check request. The default value is 80.requestPathThe request path of the HTTP health check request. The default value is /. This field does not support query parameters. Must comply with RFC3986.selfLinkServer-defined URL for the resource.timeoutSecHow long (in seconds) to wait before claiming failure. The default value is 5 seconds. It is invalid for timeoutSec to have greater value than checkIntervalSec.unhealthyThresholdA so-far healthy instance will be marked unhealthy after this many consecutive failures. The default value is 2.const -
GetHttpHealthCheckComputeBetaResult.fromMap(Map<
String, dynamic> map) -
factory
Properties
- checkIntervalSec → int
-
How often (in seconds) to send a health check. The default value is 5 seconds.
final
- creationTimestamp → String
-
Creation timestamp in RFC3339 text format.
final
- description → String
-
An optional description of this resource. Provide this property when you create the resource.
final
- hashCode → int
-
The hash code for this object.
no setterinherited
- healthyThreshold → int
-
A so-far unhealthy instance will be marked healthy after this many consecutive successes. The default value is 2.
final
- host → String
-
The value of the host header in the HTTP health check request. If left empty (default value), the public IP on behalf of which this health check is performed will be used.
final
- kind → String
-
Type of the resource. Always compute#httpHealthCheck for HTTP health checks.
final
- name → String
-
Name of the resource. Provided by the client when the resource is created. The name must be 1-63 characters long, and comply with RFC1035. Specifically, the name must be 1-63 characters long and match the regular expression
[a-z]([-a-z0-9]*[a-z0-9])?which means the first character must be a lowercase letter, and all following characters must be a dash, lowercase letter, or digit, except the last character, which cannot be a dash.final - port → int
-
The TCP port number for the HTTP health check request. The default value is 80.
final
- requestPath → String
-
The request path of the HTTP health check request. The default value is /. This field does not support query parameters. Must comply with RFC3986.
final
- runtimeType → Type
-
A representation of the runtime type of the object.
no setterinherited
- selfLink → String
-
Server-defined URL for the resource.
final
- timeoutSec → int
-
How long (in seconds) to wait before claiming failure. The default value is 5 seconds. It is invalid for timeoutSec to have greater value than checkIntervalSec.
final
- unhealthyThreshold → int
-
A so-far healthy instance will be marked unhealthy after this many consecutive failures. The default value is 2.
final
Methods
-
noSuchMethod(
Invocation invocation) → dynamic -
Invoked when a nonexistent method or property is accessed.
inherited
-
toMap(
) → Map< String, dynamic> -
toString(
) → String -
A string representation of this object.
inherited
Operators
-
operator ==(
Object other) → bool -
The equality operator.
inherited