GetHttpHealthCheckComputeBetaResult constructor
- required int checkIntervalSec,
- required String creationTimestamp,
- required String description,
- required int healthyThreshold,
- required String host,
- required String kind,
- required String name,
- required int port,
- required String requestPath,
- required String selfLink,
- required int timeoutSec,
- required int unhealthyThreshold,
Creates a new GetHttpHealthCheckComputeBetaResult.
checkIntervalSec How often (in seconds) to send a health check. The default value is 5 seconds.
creationTimestamp Creation timestamp in RFC3339 text format.
description An optional description of this resource. Provide this property when you create the resource.
healthyThreshold A so-far unhealthy instance will be marked healthy after this many consecutive successes. The default value is 2.
host The value of the host header in the HTTP health check request. If left empty (default value), the public IP on behalf of which this health check is performed will be used.
kind Type of the resource. Always compute#httpHealthCheck for HTTP health checks.
name Name of the resource. Provided by the client when the resource is created. The name must be 1-63 characters long, and comply with RFC1035. Specifically, the name must be 1-63 characters long and match the regular expression [a-z]([-a-z0-9]*[a-z0-9])? which means the first character must be a lowercase letter, and all following characters must be a dash, lowercase letter, or digit, except the last character, which cannot be a dash.
port The TCP port number for the HTTP health check request. The default value is 80.
requestPath The request path of the HTTP health check request. The default value is /. This field does not support query parameters. Must comply with RFC3986.
selfLink Server-defined URL for the resource.
timeoutSec How long (in seconds) to wait before claiming failure. The default value is 5 seconds. It is invalid for timeoutSec to have greater value than checkIntervalSec.
unhealthyThreshold A so-far healthy instance will be marked unhealthy after this many consecutive failures. The default value is 2.
Implementation
const GetHttpHealthCheckComputeBetaResult({
required this.checkIntervalSec,
required this.creationTimestamp,
required this.description,
required this.healthyThreshold,
required this.host,
required this.kind,
required this.name,
required this.port,
required this.requestPath,
required this.selfLink,
required this.timeoutSec,
required this.unhealthyThreshold,
});