package_info_tizen

The Tizen implementation of package_info.

Usage

This package is not an endorsed implementation of package_info. Therefore, you have to include package_info_tizen alongside package_info as dependencies in your pubspec.yaml file.

dependencies:
  package_info: ^0.4.3
  package_info_tizen: ^1.0.0

Then you can import package_info in your Dart code:

import 'package:package_info/package_info.dart';

PackageInfo packageInfo = await PackageInfo.fromPlatform();

String appName = packageInfo.appName;
String packageName = packageInfo.packageName;
String version = packageInfo.version;
String buildNumber = packageInfo.buildNumber;

Or in async mode:

PackageInfo.fromPlatform().then((PackageInfo packageInfo) {
  String appName = packageInfo.appName;
  String packageName = packageInfo.packageName;
  String version = packageInfo.version;
  String buildNumber = packageInfo.buildNumber;
});

For detailed usage, see https://github.com/flutter/plugins/blob/master/packages/package_info/README.md#usage.

Supported devices

This plugin is supported on these types of devices:

  • Galaxy Watch (running Tizen 4.0 or later)