:bird: flutter_feathersjs :bird:

pub points likes popularity GitHub Repo stars pub version GitHub last commit

FlutterFeathersJs Icon
Communicate with your feathers js server from flutter app with unbelieved ease and make happy your customers.


Infos: Feathers js is a node framework for real-time applications and REST APIs.


Simple to use

1. Install it

# Please see https://pub.dev/packages/flutter_feathersjs/install
flutter_feathersjs: ^lastest

2. Import it

// Import it
import 'package:flutter_feathersjs/flutter_feathersjs.dart';

3. Initialize it



//your  api baseUrl
const BASE_URL = "https://flutter-feathersjs.herokuapp.com";

// Init it globally across your app, maybe with get_it or something like that
FlutterFeathersjs flutterFeathersjs = FlutterFeathersjs()
    ..init(baseUrl: BASE_URL);

You're ready to go: 3, 2, 1 :rocket: Checkout the doc for more info.

Notes

:bird: This package can be used in prod env from version V3.0.0 and up :rocket:.

:bird: This package is tested with feathersjs v4.x

:bird: Great features will be added soonly (Learn more here). These feature will introduce incompatibilities with previous versions.

:bird: Null safety supported from version V4.0.2.

:bird: See pubspec.yaml for more infos.

Documentation

Check it out at: https://dahkenangnon.github.io/flutter_feathersjs.dart/

Support

Please email to dah.kenangnon (at) gmail (dot) com if you have any questions or comments or business support.

Contributing

Please feel free to contribute to this project by opening an issue or creating a pull request.

Libraries

flutter_feathersjs
Communicate with your feathers js server from flutter app with unbelieved ease and make happy your customers.