Unicons

A Flutter library for Unicons.

Note: All icon data is auto-generated based on the latest release of Unicons.

style: effective dart GitHub repo size Project Owner GitHub stars GitHub forks

Installation

Add the dependency to your pubspec.yaml file.

If your project has null safety enabled, you can use the latest version:

dependencies:
  unicons: ^2.0.1

If your project does not use null safety, you should use the following version:

dependencies:
  unicons: 1.0.1

Usage

The library exposes all of the Unicons as IconData. If you want to use Line icons, use UniconsLine class, but if you want to use Solid icons, use UniconsSolid instead.

import 'package:flutter/material.dart';
import 'package:unicons/unicons.dart';

class MyWidget extends StatelessWidget {
  Widget build(BuildContext context) {
    return Container(
      height: MediaQuery.of(context).size.height,
      width: MediaQuery.of(context).size.width,
      child: Column(
        mainAxisAlignment: MainAxisAlignment.center,
        crossAxisAlignment: CrossAxisAlignment.center,
        children: [
          Icon(UniconsLine.camera),
          Icon(UniconsLine.baseball_ball),
          Icon(UniconsSolid.airplay),
          Icon(UniconsSolid.battery_empty),
        ],
      ),
    );
  }
}

License

Unicons are Open Source icons and licensed under Apache 2.0. You're free to use these icons in your personal and commercial project. We would love to see the attribution in your app's about screen, but it's not mandatory.

Libraries

unicons