SubjectAltNames class

SubjectAltNames corresponds to a more modern way of listing what the asserted identity is in a certificate (i.e., compared to the "common name" in the distinguished name).

Constructors

SubjectAltNames({Input<List<X509Extension>>? customSans, Input<List<String>>? dnsNames, Input<List<String>>? emailAddresses, Input<List<String>>? ipAddresses, Input<List<String>>? uris})
Creates a new SubjectAltNames. customSans Contains additional subject alternative name values. For each custom_san, the value field must contain an ASN.1 encoded UTF8String. dnsNames Contains only valid, fully-qualified host names. emailAddresses Contains only valid RFC 2822 E-mail addresses. ipAddresses Contains only valid 32-bit IPv4 addresses or RFC 4291 IPv6 addresses. uris Contains only valid RFC 3986 URIs.
const
SubjectAltNames.fromMap(Map<String, dynamic> map)
factory

Properties

customSans → Input<List<X509Extension>>?
Contains additional subject alternative name values. For each custom_san, the value field must contain an ASN.1 encoded UTF8String.
final
dnsNames → Input<List<String>>?
Contains only valid, fully-qualified host names.
final
emailAddresses → Input<List<String>>?
Contains only valid RFC 2822 E-mail addresses.
final
hashCode → int
The hash code for this object.
no setterinherited
ipAddresses → Input<List<String>>?
Contains only valid 32-bit IPv4 addresses or RFC 4291 IPv6 addresses.
final
runtimeType → Type
A representation of the runtime type of the object.
no setterinherited
uris → Input<List<String>>?
Contains only valid RFC 3986 URIs.
final

Methods

noSuchMethod(Invocation invocation) → dynamic
Invoked when a nonexistent method or property is accessed.
inherited
toMap() → Map<String, dynamic>
toString() → String
A string representation of this object.
inherited

Operators

operator ==(Object other) → bool
The equality operator.
inherited