RouteComputeV1Args class
The set of arguments for Route. The set of arguments for Route.
Constructors
-
RouteComputeV1Args({Input<
String> ? description, Input<String> ? destRange, Input<String> ? name, Input<String> ? network, Input<String> ? nextHopGateway, Input<String> ? nextHopIlb, Input<String> ? nextHopInstance, Input<String> ? nextHopIp, Input<String> ? nextHopNetwork, Input<String> ? nextHopVpnTunnel, Input<int> ? priority, Input<String> ? project, Input<String> ? requestId, Input<List< ? tags})String> > -
Creates a new RouteComputeV1Args.
descriptionAn optional description of this resource. Provide this field when you create the resource.destRangeThe destination range of outgoing packets that this route applies to. Both IPv4 and IPv6 are supported. Must specify an IPv4 range (e.g. 192.0.2.0/24) or an IPv6 range in RFC 4291 format (e.g. 2001:db8::/32). IPv6 range will be displayed using RFC 5952 compressed format.nameName of the resource. Provided by the client when the resource is created. The name must be 1-63 characters long, and comply with RFC1035. Specifically, the name must be 1-63 characters long and match the regular expression[a-z]([-a-z0-9]*[a-z0-9])?. The first character must be a lowercase letter, and all following characters (except for the last character) must be a dash, lowercase letter, or digit. The last character must be a lowercase letter or digit.networkFully-qualified URL of the network that this route applies to.nextHopGatewayThe URL to a gateway that should handle matching packets. You can only specify the internet gateway using a full or partial valid URL: projects/ project/global/gateways/default-internet-gatewaynextHopIlbThe URL to a forwarding rule of type loadBalancingScheme=INTERNAL that should handle matching packets or the IP address of the forwarding Rule. For example, the following are all valid URLs: - 10.128.0.56 - https://www.googleapis.com/compute/v1/projects/project/regions/region /forwardingRules/forwardingRule - regions/region/forwardingRules/forwardingRulenextHopInstanceThe URL to an instance that should handle matching packets. You can specify this as a full or partial URL. For example: https://www.googleapis.com/compute/v1/projects/project/zones/zone/instances/nextHopIpThe network IP address of an instance that should handle matching packets. Both IPv6 address and IPv4 addresses are supported. Must specify an IPv4 address in dot-decimal notation (e.g. 192.0.2.99) or an IPv6 address in RFC 4291 format (e.g. 2001:db8::2d9:51:0:0 or 2001:db8:0:0:2d9:51:0:0). IPv6 addresses will be displayed using RFC 5952 compressed format (e.g. 2001:db8::2d9:51:0:0). Should never be an IPv4-mapped IPv6 address.nextHopNetworkThe URL of the local network if it should handle matching packets.nextHopVpnTunnelThe URL to a VpnTunnel that should handle matching packets.priorityThe priority of this route. Priority is used to break ties in cases where there is more than one matching route of equal prefix length. In cases where multiple routes have equal prefix length, the one with the lowest-numbered priority value wins. The default value is1000. The priority value must be from0to65535, inclusive.projectOptional.requestIdAn optional request ID to identify requests. Specify a unique request ID so that if you must retry your request, the server will know to ignore the request if it has already been completed. For example, consider a situation where you make an initial request and the request times out. If you make the request again with the same request ID, the server can check if original operation with the same request ID was received, and if so, will ignore the second request. This prevents clients from accidentally creating duplicate commitments. The request ID must be a valid UUID with the exception that zero UUID is not supported ( 00000000-0000-0000-0000-000000000000).tagsA list of instance tags to which this route applies.const -
RouteComputeV1Args.fromMap(Map<
String, dynamic> map) -
factory
Properties
-
description
→ Input<
String> ? -
An optional description of this resource. Provide this field when you create the resource.
final
-
destRange
→ Input<
String> ? -
The destination range of outgoing packets that this route applies to. Both IPv4 and IPv6 are supported. Must specify an IPv4 range (e.g. 192.0.2.0/24) or an IPv6 range in RFC 4291 format (e.g. 2001:db8::/32). IPv6 range will be displayed using RFC 5952 compressed format.
final
- hashCode → int
-
The hash code for this object.
no setterinherited
-
name
→ Input<
String> ? -
Name of the resource. Provided by the client when the resource is created. The name must be 1-63 characters long, and comply with RFC1035. Specifically, the name must be 1-63 characters long and match the regular expression
[a-z]([-a-z0-9]*[a-z0-9])?. The first character must be a lowercase letter, and all following characters (except for the last character) must be a dash, lowercase letter, or digit. The last character must be a lowercase letter or digit.final -
network
→ Input<
String> ? -
Fully-qualified URL of the network that this route applies to.
final
-
nextHopGateway
→ Input<
String> ? -
The URL to a gateway that should handle matching packets. You can only specify the internet gateway using a full or partial valid URL: projects/ project/global/gateways/default-internet-gateway
final
-
nextHopIlb
→ Input<
String> ? -
The URL to a forwarding rule of type loadBalancingScheme=INTERNAL that should handle matching packets or the IP address of the forwarding Rule. For example, the following are all valid URLs: - 10.128.0.56 - https://www.googleapis.com/compute/v1/projects/project/regions/region /forwardingRules/forwardingRule - regions/region/forwardingRules/forwardingRule
final
-
nextHopInstance
→ Input<
String> ? -
The URL to an instance that should handle matching packets. You can specify this as a full or partial URL. For example: https://www.googleapis.com/compute/v1/projects/project/zones/zone/instances/
final
-
nextHopIp
→ Input<
String> ? -
The network IP address of an instance that should handle matching packets. Both IPv6 address and IPv4 addresses are supported. Must specify an IPv4 address in dot-decimal notation (e.g. 192.0.2.99) or an IPv6 address in RFC 4291 format (e.g. 2001:db8::2d9:51:0:0 or 2001:db8:0:0:2d9:51:0:0). IPv6 addresses will be displayed using RFC 5952 compressed format (e.g. 2001:db8::2d9:51:0:0). Should never be an IPv4-mapped IPv6 address.
final
-
nextHopNetwork
→ Input<
String> ? -
The URL of the local network if it should handle matching packets.
final
-
nextHopVpnTunnel
→ Input<
String> ? -
The URL to a VpnTunnel that should handle matching packets.
final
-
priority
→ Input<
int> ? -
The priority of this route. Priority is used to break ties in cases where there is more than one matching route of equal prefix length. In cases where multiple routes have equal prefix length, the one with the lowest-numbered priority value wins. The default value is
1000. The priority value must be from0to65535, inclusive.final -
project
→ Input<
String> ? -
final
-
requestId
→ Input<
String> ? -
An optional request ID to identify requests. Specify a unique request ID so that if you must retry your request, the server will know to ignore the request if it has already been completed. For example, consider a situation where you make an initial request and the request times out. If you make the request again with the same request ID, the server can check if original operation with the same request ID was received, and if so, will ignore the second request. This prevents clients from accidentally creating duplicate commitments. The request ID must be a valid UUID with the exception that zero UUID is not supported ( 00000000-0000-0000-0000-000000000000).
final
- runtimeType → Type
-
A representation of the runtime type of the object.
no setterinherited
-
A list of instance tags to which this route applies.
final
Methods
-
noSuchMethod(
Invocation invocation) → dynamic -
Invoked when a nonexistent method or property is accessed.
inherited
-
toMap(
) → Map< String, dynamic> -
toString(
) → String -
A string representation of this object.
inherited
Operators
-
operator ==(
Object other) → bool -
The equality operator.
inherited