GetRouteResult class

Result data returned by getRoute.

Constructors

GetRouteResult({required bool allowConflictingSubnetworks, required List<RouteAsPathResponse> asPaths, required String creationTimestamp, required String description, required String destRange, required String ilbRouteBehaviorOnUnhealthy, required String kind, required String name, required String network, required String nextHopGateway, required String nextHopHub, required String nextHopIlb, required String nextHopInstance, required int nextHopInterRegionCost, required String nextHopInterconnectAttachment, required String nextHopIp, required int nextHopMed, required String nextHopNetwork, required String nextHopOrigin, required String nextHopPeering, required String nextHopVpnTunnel, required int priority, required String routeStatus, required String routeType, required String selfLink, required String selfLinkWithId, required List<String> tags, required List<RouteWarningsItemResponse> warnings})
Creates a new GetRouteResult. allowConflictingSubnetworks Whether this route can conflict with existing subnetworks. Setting this to true allows this route to conflict with subnetworks that have already been configured on the corresponding network. asPaths AS path. creationTimestamp Creation timestamp in RFC3339 text format. description An optional description of this resource. Provide this field when you create the resource. destRange The destination range of outgoing packets that this route applies to. Both IPv4 and IPv6 are supported. Must specify an IPv4 range (e.g. 192.0.2.0/24) or an IPv6 range in RFC 4291 format (e.g. 2001:db8::/32). IPv6 range will be displayed using RFC 5952 compressed format. ilbRouteBehaviorOnUnhealthy ILB route behavior when ILB is deemed unhealthy based on user specified threshold on the Backend Service of the internal load balancing. kind Type of this resource. Always compute#routes for Route resources. name Name of the resource. Provided by the client when the resource is created. The name must be 1-63 characters long, and comply with RFC1035. Specifically, the name must be 1-63 characters long and match the regular expression [a-z]([-a-z0-9]*[a-z0-9])?. The first character must be a lowercase letter, and all following characters (except for the last character) must be a dash, lowercase letter, or digit. The last character must be a lowercase letter or digit. network Fully-qualified URL of the network that this route applies to. nextHopGateway The URL to a gateway that should handle matching packets. You can only specify the internet gateway using a full or partial valid URL: projects/ project/global/gateways/default-internet-gateway nextHopHub The full resource name of the Network Connectivity Center hub that will handle matching packets. nextHopIlb The URL to a forwarding rule of type loadBalancingScheme=INTERNAL that should handle matching packets or the IP address of the forwarding Rule. For example, the following are all valid URLs: - 10.128.0.56 - https://www.googleapis.com/compute/v1/projects/project/regions/region /forwardingRules/forwardingRule - regions/region/forwardingRules/forwardingRule nextHopInstance The URL to an instance that should handle matching packets. You can specify this as a full or partial URL. For example: https://www.googleapis.com/compute/v1/projects/project/zones/zone/instances/ nextHopInterRegionCost Output only Internal fixed region-to-region cost that Google Cloud calculates based on factors such as network performance, distance, and available bandwidth between regions. nextHopInterconnectAttachment The URL to an InterconnectAttachment which is the next hop for the route. This field will only be populated for the dynamic routes generated by Cloud Router with a linked interconnectAttachment. nextHopIp The network IP address of an instance that should handle matching packets. Both IPv6 address and IPv4 addresses are supported. Must specify an IPv4 address in dot-decimal notation (e.g. 192.0.2.99) or an IPv6 address in RFC 4291 format (e.g. 2001:db8::2d9:51:0:0 or 2001:db8:0:0:2d9:51:0:0). IPv6 addresses will be displayed using RFC 5952 compressed format (e.g. 2001:db8::2d9:51:0:0). Should never be an IPv4-mapped IPv6 address. nextHopMed Multi-Exit Discriminator, a BGP route metric that indicates the desirability of a particular route in a network. nextHopNetwork The URL of the local network if it should handle matching packets. nextHopOrigin Indicates the origin of the route. Can be IGP (Interior Gateway Protocol), EGP (Exterior Gateway Protocol), or INCOMPLETE. nextHopPeering The network peering name that should handle matching packets, which should conform to RFC1035. nextHopVpnTunnel The URL to a VpnTunnel that should handle matching packets. priority The priority of this route. Priority is used to break ties in cases where there is more than one matching route of equal prefix length. In cases where multiple routes have equal prefix length, the one with the lowest-numbered priority value wins. The default value is 1000. The priority value must be from 0 to 65535, inclusive. routeStatus Output only The status of the route. routeType The type of this route, which can be one of the following values: - 'TRANSIT' for a transit route that this router learned from another Cloud Router and will readvertise to one of its BGP peers - 'SUBNET' for a route from a subnet of the VPC - 'BGP' for a route learned from a BGP peer of this router - 'STATIC' for a static route selfLink Server-defined fully-qualified URL for this resource. selfLinkWithId Server-defined URL for this resource with the resource id. tags A list of instance tags to which this route applies. warnings If potential misconfigurations are detected for this route, this field will be populated with warning messages.
const
GetRouteResult.fromMap(Map<String, dynamic> map)
factory

Properties

allowConflictingSubnetworks → bool
Whether this route can conflict with existing subnetworks. Setting this to true allows this route to conflict with subnetworks that have already been configured on the corresponding network.
final
asPaths → List<RouteAsPathResponse>
AS path.
final
creationTimestamp → String
Creation timestamp in RFC3339 text format.
final
description → String
An optional description of this resource. Provide this field when you create the resource.
final
destRange → String
The destination range of outgoing packets that this route applies to. Both IPv4 and IPv6 are supported. Must specify an IPv4 range (e.g. 192.0.2.0/24) or an IPv6 range in RFC 4291 format (e.g. 2001:db8::/32). IPv6 range will be displayed using RFC 5952 compressed format.
final
hashCode → int
The hash code for this object.
no setterinherited
ilbRouteBehaviorOnUnhealthy → String
ILB route behavior when ILB is deemed unhealthy based on user specified threshold on the Backend Service of the internal load balancing.
final
kind → String
Type of this resource. Always compute#routes for Route resources.
final
name → String
Name of the resource. Provided by the client when the resource is created. The name must be 1-63 characters long, and comply with RFC1035. Specifically, the name must be 1-63 characters long and match the regular expression [a-z]([-a-z0-9]*[a-z0-9])?. The first character must be a lowercase letter, and all following characters (except for the last character) must be a dash, lowercase letter, or digit. The last character must be a lowercase letter or digit.
final
network → String
Fully-qualified URL of the network that this route applies to.
final
nextHopGateway → String
The URL to a gateway that should handle matching packets. You can only specify the internet gateway using a full or partial valid URL: projects/ project/global/gateways/default-internet-gateway
final
nextHopHub → String
The full resource name of the Network Connectivity Center hub that will handle matching packets.
final
nextHopIlb → String
The URL to a forwarding rule of type loadBalancingScheme=INTERNAL that should handle matching packets or the IP address of the forwarding Rule. For example, the following are all valid URLs: - 10.128.0.56 - https://www.googleapis.com/compute/v1/projects/project/regions/region /forwardingRules/forwardingRule - regions/region/forwardingRules/forwardingRule
final
nextHopInstance → String
The URL to an instance that should handle matching packets. You can specify this as a full or partial URL. For example: https://www.googleapis.com/compute/v1/projects/project/zones/zone/instances/
final
nextHopInterconnectAttachment → String
The URL to an InterconnectAttachment which is the next hop for the route. This field will only be populated for the dynamic routes generated by Cloud Router with a linked interconnectAttachment.
final
nextHopInterRegionCost → int
Output only Internal fixed region-to-region cost that Google Cloud calculates based on factors such as network performance, distance, and available bandwidth between regions.
final
nextHopIp → String
The network IP address of an instance that should handle matching packets. Both IPv6 address and IPv4 addresses are supported. Must specify an IPv4 address in dot-decimal notation (e.g. 192.0.2.99) or an IPv6 address in RFC 4291 format (e.g. 2001:db8::2d9:51:0:0 or 2001:db8:0:0:2d9:51:0:0). IPv6 addresses will be displayed using RFC 5952 compressed format (e.g. 2001:db8::2d9:51:0:0). Should never be an IPv4-mapped IPv6 address.
final
nextHopMed → int
Multi-Exit Discriminator, a BGP route metric that indicates the desirability of a particular route in a network.
final
nextHopNetwork → String
The URL of the local network if it should handle matching packets.
final
nextHopOrigin → String
Indicates the origin of the route. Can be IGP (Interior Gateway Protocol), EGP (Exterior Gateway Protocol), or INCOMPLETE.
final
nextHopPeering → String
The network peering name that should handle matching packets, which should conform to RFC1035.
final
nextHopVpnTunnel → String
The URL to a VpnTunnel that should handle matching packets.
final
priority → int
The priority of this route. Priority is used to break ties in cases where there is more than one matching route of equal prefix length. In cases where multiple routes have equal prefix length, the one with the lowest-numbered priority value wins. The default value is 1000. The priority value must be from 0 to 65535, inclusive.
final
routeStatus → String
Output only The status of the route.
final
routeType → String
The type of this route, which can be one of the following values: - 'TRANSIT' for a transit route that this router learned from another Cloud Router and will readvertise to one of its BGP peers - 'SUBNET' for a route from a subnet of the VPC - 'BGP' for a route learned from a BGP peer of this router - 'STATIC' for a static route
final
runtimeType → Type
A representation of the runtime type of the object.
no setterinherited
Server-defined fully-qualified URL for this resource.
final
selfLinkWithId → String
Server-defined URL for this resource with the resource id.
final
tags → List<String>
A list of instance tags to which this route applies.
final
warnings → List<RouteWarningsItemResponse>
If potential misconfigurations are detected for this route, this field will be populated with warning messages.
final

Methods

noSuchMethod(Invocation invocation) → dynamic
Invoked when a nonexistent method or property is accessed.
inherited
toMap() → Map<String, dynamic>
toString() → String
A string representation of this object.
inherited

Operators

operator ==(Object other) → bool
The equality operator.
inherited