GetRouteComputeV1Result class
Result data returned by getRoute.
Constructors
-
GetRouteComputeV1Result({required List<
RouteAsPathResponseComputeV1> asPaths, required String creationTimestamp, required String description, required String destRange, required String kind, required String name, required String network, required String nextHopGateway, required String nextHopHub, required String nextHopIlb, required String nextHopInstance, required String nextHopIp, required String nextHopNetwork, required String nextHopPeering, required String nextHopVpnTunnel, required int priority, required String routeStatus, required String routeType, required String selfLink, required List<String> tags, required List<RouteWarningsItemResponseComputeV1> warnings}) -
Creates a new GetRouteComputeV1Result.
asPathsAS path.creationTimestampCreation timestamp in RFC3339 text format.descriptionAn optional description of this resource. Provide this field when you create the resource.destRangeThe destination range of outgoing packets that this route applies to. Both IPv4 and IPv6 are supported. Must specify an IPv4 range (e.g. 192.0.2.0/24) or an IPv6 range in RFC 4291 format (e.g. 2001:db8::/32). IPv6 range will be displayed using RFC 5952 compressed format.kindType of this resource. Always compute#routes for Route resources.nameName of the resource. Provided by the client when the resource is created. The name must be 1-63 characters long, and comply with RFC1035. Specifically, the name must be 1-63 characters long and match the regular expression[a-z]([-a-z0-9]*[a-z0-9])?. The first character must be a lowercase letter, and all following characters (except for the last character) must be a dash, lowercase letter, or digit. The last character must be a lowercase letter or digit.networkFully-qualified URL of the network that this route applies to.nextHopGatewayThe URL to a gateway that should handle matching packets. You can only specify the internet gateway using a full or partial valid URL: projects/ project/global/gateways/default-internet-gatewaynextHopHubThe full resource name of the Network Connectivity Center hub that will handle matching packets.nextHopIlbThe URL to a forwarding rule of type loadBalancingScheme=INTERNAL that should handle matching packets or the IP address of the forwarding Rule. For example, the following are all valid URLs: - 10.128.0.56 - https://www.googleapis.com/compute/v1/projects/project/regions/region /forwardingRules/forwardingRule - regions/region/forwardingRules/forwardingRulenextHopInstanceThe URL to an instance that should handle matching packets. You can specify this as a full or partial URL. For example: https://www.googleapis.com/compute/v1/projects/project/zones/zone/instances/nextHopIpThe network IP address of an instance that should handle matching packets. Both IPv6 address and IPv4 addresses are supported. Must specify an IPv4 address in dot-decimal notation (e.g. 192.0.2.99) or an IPv6 address in RFC 4291 format (e.g. 2001:db8::2d9:51:0:0 or 2001:db8:0:0:2d9:51:0:0). IPv6 addresses will be displayed using RFC 5952 compressed format (e.g. 2001:db8::2d9:51:0:0). Should never be an IPv4-mapped IPv6 address.nextHopNetworkThe URL of the local network if it should handle matching packets.nextHopPeeringThe network peering name that should handle matching packets, which should conform to RFC1035.nextHopVpnTunnelThe URL to a VpnTunnel that should handle matching packets.priorityThe priority of this route. Priority is used to break ties in cases where there is more than one matching route of equal prefix length. In cases where multiple routes have equal prefix length, the one with the lowest-numbered priority value wins. The default value is1000. The priority value must be from0to65535, inclusive. routeStatusOutput onlyThe status of the route.routeTypeThe type of this route, which can be one of the following values: - 'TRANSIT' for a transit route that this router learned from another Cloud Router and will readvertise to one of its BGP peers - 'SUBNET' for a route from a subnet of the VPC - 'BGP' for a route learned from a BGP peer of this router - 'STATIC' for a static routeselfLinkServer-defined fully-qualified URL for this resource.tagsA list of instance tags to which this route applies.warningsIf potential misconfigurations are detected for this route, this field will be populated with warning messages.const -
GetRouteComputeV1Result.fromMap(Map<
String, dynamic> map) -
factory
Properties
-
asPaths
→ List<
RouteAsPathResponseComputeV1> -
AS path.
final
- creationTimestamp → String
-
Creation timestamp in RFC3339 text format.
final
- description → String
-
An optional description of this resource. Provide this field when you create the resource.
final
- destRange → String
-
The destination range of outgoing packets that this route applies to. Both IPv4 and IPv6 are supported. Must specify an IPv4 range (e.g. 192.0.2.0/24) or an IPv6 range in RFC 4291 format (e.g. 2001:db8::/32). IPv6 range will be displayed using RFC 5952 compressed format.
final
- hashCode → int
-
The hash code for this object.
no setterinherited
- kind → String
-
Type of this resource. Always compute#routes for Route resources.
final
- name → String
-
Name of the resource. Provided by the client when the resource is created. The name must be 1-63 characters long, and comply with RFC1035. Specifically, the name must be 1-63 characters long and match the regular expression
[a-z]([-a-z0-9]*[a-z0-9])?. The first character must be a lowercase letter, and all following characters (except for the last character) must be a dash, lowercase letter, or digit. The last character must be a lowercase letter or digit.final - network → String
-
Fully-qualified URL of the network that this route applies to.
final
- nextHopGateway → String
-
The URL to a gateway that should handle matching packets. You can only specify the internet gateway using a full or partial valid URL: projects/ project/global/gateways/default-internet-gateway
final
- nextHopHub → String
-
The full resource name of the Network Connectivity Center hub that will handle matching packets.
final
- nextHopIlb → String
-
The URL to a forwarding rule of type loadBalancingScheme=INTERNAL that should handle matching packets or the IP address of the forwarding Rule. For example, the following are all valid URLs: - 10.128.0.56 - https://www.googleapis.com/compute/v1/projects/project/regions/region /forwardingRules/forwardingRule - regions/region/forwardingRules/forwardingRule
final
- nextHopInstance → String
-
The URL to an instance that should handle matching packets. You can specify this as a full or partial URL. For example: https://www.googleapis.com/compute/v1/projects/project/zones/zone/instances/
final
- nextHopIp → String
-
The network IP address of an instance that should handle matching packets. Both IPv6 address and IPv4 addresses are supported. Must specify an IPv4 address in dot-decimal notation (e.g. 192.0.2.99) or an IPv6 address in RFC 4291 format (e.g. 2001:db8::2d9:51:0:0 or 2001:db8:0:0:2d9:51:0:0). IPv6 addresses will be displayed using RFC 5952 compressed format (e.g. 2001:db8::2d9:51:0:0). Should never be an IPv4-mapped IPv6 address.
final
- nextHopNetwork → String
-
The URL of the local network if it should handle matching packets.
final
- nextHopPeering → String
-
The network peering name that should handle matching packets, which should conform to RFC1035.
final
- nextHopVpnTunnel → String
-
The URL to a VpnTunnel that should handle matching packets.
final
- priority → int
-
The priority of this route. Priority is used to break ties in cases where there is more than one matching route of equal prefix length. In cases where multiple routes have equal prefix length, the one with the lowest-numbered priority value wins. The default value is
1000. The priority value must be from0to65535, inclusive.final - routeStatus → String
-
Output onlyThe status of the route.final - routeType → String
-
The type of this route, which can be one of the following values: - 'TRANSIT' for a transit route that this router learned from another Cloud Router and will readvertise to one of its BGP peers - 'SUBNET' for a route from a subnet of the VPC - 'BGP' for a route learned from a BGP peer of this router - 'STATIC' for a static route
final
- runtimeType → Type
-
A representation of the runtime type of the object.
no setterinherited
- selfLink → String
-
Server-defined fully-qualified URL for this resource.
final
-
A list of instance tags to which this route applies.
final
-
warnings
→ List<
RouteWarningsItemResponseComputeV1> -
If potential misconfigurations are detected for this route, this field will be populated with warning messages.
final
Methods
-
noSuchMethod(
Invocation invocation) → dynamic -
Invoked when a nonexistent method or property is accessed.
inherited
-
toMap(
) → Map< String, dynamic> -
toString(
) → String -
A string representation of this object.
inherited
Operators
-
operator ==(
Object other) → bool -
The equality operator.
inherited