SubjectAltNamesResponse class
SubjectAltNames corresponds to a more modern way of listing what the asserted identity is in a certificate (i.e., compared to the "common name" in the distinguished name).
Constructors
-
SubjectAltNamesResponse({required Input<
List< customSans, required Input<X509ExtensionResponse> >List< dnsNames, required Input<String> >List< emailAddresses, required Input<String> >List< ipAddresses, required Input<String> >List< uris})String> > -
Creates a new SubjectAltNamesResponse.
customSansContains additional subject alternative name values. For each custom_san, thevaluefield must contain an ASN.1 encoded UTF8String.dnsNamesContains only valid, fully-qualified host names.emailAddressesContains only valid RFC 2822 E-mail addresses.ipAddressesContains only valid 32-bit IPv4 addresses or RFC 4291 IPv6 addresses.urisContains only valid RFC 3986 URIs.const -
SubjectAltNamesResponse.fromMap(Map<
String, dynamic> map) -
factory
Properties
-
customSans
→ Input<
List< X509ExtensionResponse> > -
Contains additional subject alternative name values. For each custom_san, the
valuefield must contain an ASN.1 encoded UTF8String.final -
dnsNames
→ Input<
List< String> > -
Contains only valid, fully-qualified host names.
final
-
emailAddresses
→ Input<
List< String> > -
Contains only valid RFC 2822 E-mail addresses.
final
- hashCode → int
-
The hash code for this object.
no setterinherited
-
ipAddresses
→ Input<
List< String> > -
Contains only valid 32-bit IPv4 addresses or RFC 4291 IPv6 addresses.
final
- runtimeType → Type
-
A representation of the runtime type of the object.
no setterinherited
-
uris
→ Input<
List< String> > -
Contains only valid RFC 3986 URIs.
final
Methods
-
noSuchMethod(
Invocation invocation) → dynamic -
Invoked when a nonexistent method or property is accessed.
inherited
-
toMap(
) → Map< String, dynamic> -
toString(
) → String -
A string representation of this object.
inherited
Operators
-
operator ==(
Object other) → bool -
The equality operator.
inherited