InterconnectAttachmentState class

Input properties used for looking up and filtering InterconnectAttachment resources.

Constructors

InterconnectAttachmentState({Input<bool?>? adminEnabled, Input<String?>? attachmentGroup, Input<String?>? bandwidth, Input<String?>? candidateCloudRouterIpAddress, Input<String?>? candidateCloudRouterIpv6Address, Input<String?>? candidateCustomerRouterIpAddress, Input<String?>? candidateCustomerRouterIpv6Address, Input<List<String>?>? candidateSubnets, Input<String?>? cloudRouterIpAddress, Input<String?>? cloudRouterIpv6Address, Input<String?>? creationTimestamp, Input<String?>? customerRouterIpAddress, Input<String?>? customerRouterIpv6Address, Input<String?>? deletionPolicy, Input<String?>? description, Input<String?>? edgeAvailabilityDomain, Input<Map<String, String>?>? effectiveLabels, Input<String?>? encryption, Input<String?>? googleReferenceId, Input<String?>? interconnect, Input<List<String>?>? ipsecInternalAddresses, Input<InterconnectAttachmentL2Forwarding?>? l2Forwarding, Input<String?>? labelFingerprint, Input<Map<String, String>?>? labels, Input<String?>? mtu, Input<String?>? name, Input<String?>? pairingKey, Input<InterconnectAttachmentParams?>? params, Input<String?>? partnerAsn, Input<List<InterconnectAttachmentPrivateInterconnectInfo>?>? privateInterconnectInfos, Input<String?>? project, Input<Map<String, String>?>? pulumiLabels, Input<String?>? region, Input<String?>? router, Input<String?>? selfLink, Input<String?>? stackType, Input<String?>? state, Input<int?>? subnetLength, Input<String?>? type, Input<int?>? vlanTag8021q})
Creates a new InterconnectAttachmentState. adminEnabled Whether the VLAN attachment is enabled or disabled. When using attachmentGroup URL of the AttachmentGroup that includes this Attachment. bandwidth Provisioned bandwidth capacity for the interconnect attachment. candidateCloudRouterIpAddress Single IPv4 address + prefix length to be configured on the cloud router interface for this candidateCloudRouterIpv6Address Single IPv6 address + prefix length to be configured on the cloud router interface for this candidateCustomerRouterIpAddress Single IPv4 address + prefix length to be configured on the customer router interface for this candidateCustomerRouterIpv6Address Single IPv6 address + prefix length to be configured on the customer router interface for this candidateSubnets Up to 16 candidate prefixes that can be used to restrict the allocation cloudRouterIpAddress IPv4 address + prefix length to be configured on Cloud Router cloudRouterIpv6Address IPv6 address + prefix length to be configured on Cloud Router creationTimestamp Creation timestamp in RFC3339 text format. customerRouterIpAddress IPv4 address + prefix length to be configured on the customer customerRouterIpv6Address IPv6 address + prefix length to be configured on the customer deletionPolicy Whether Terraform will be prevented from destroying the resource. Defaults to DELETE. description An optional description of this resource. edgeAvailabilityDomain Desired availability domain for the attachment. Only available for type effectiveLabels All of labels (key/value pairs) present on the resource in GCP, including the labels configured through Pulumi, other clients and services. encryption Indicates the user-supplied encryption option of this interconnect googleReferenceId Google reference ID, to be used when raising support tickets with interconnect URL of the underlying Interconnect object that this attachment's ipsecInternalAddresses URL of addresses that have been reserved for the interconnect attachment, l2Forwarding L2 Interconnect Attachment related configuration. labelFingerprint A fingerprint for the labels being applied to this Interconnect, which is essentially a hash labels Labels for this resource. These can only be added or modified by the setLabels mtu Maximum Transmission Unit (MTU), in bytes, of packets passing through this interconnect attachment. name Name of the resource. Provided by the client when the resource is created. The pairingKey Output only for type PARTNER. Not present for DEDICATED. The opaque params Additional params passed with the request, but not persisted as part of resource payload partnerAsn Output only for type PARTNER. Not present for DEDICATED. Optional privateInterconnectInfos Information specific to an InterconnectAttachment. This property project The ID of the project in which the resource belongs. pulumiLabels The combination of labels configured directly on the resource region Region where the regional interconnect attachment resides. router URL of the cloud router to be used for dynamic routing. This router must be in selfLink The URI of the created resource. stackType The stack type for this interconnect attachment to identify whether the IPv6 state Output Only The current state of this attachment's functionality. subnetLength Length of the IPv4 subnet mask. Allowed values: 29 (default), 30. The default value is 29, type The type of InterconnectAttachment you wish to create. Defaults to vlanTag8021q The IEEE 802.1Q VLAN tag for this attachment, in the range 2-4094. When
const
InterconnectAttachmentState.fromMap(Map<String, dynamic> map)
factory

Properties

adminEnabled → Input<bool?>?
Whether the VLAN attachment is enabled or disabled. When using PARTNER type this will Pre-Activate the interconnect attachment
final
attachmentGroup → Input<String?>?
URL of the AttachmentGroup that includes this Attachment.
final
bandwidth → Input<String?>?
Provisioned bandwidth capacity for the interconnect attachment. For attachments of type DEDICATED, the user can set the bandwidth. For attachments of type PARTNER, the Google Partner that is operating the interconnect must set the bandwidth. Output only for PARTNER type, mutable for PARTNER_PROVIDER and DEDICATED, Defaults to BPS_10G Possible values are: BPS_50M, BPS_100M, BPS_200M, BPS_300M, BPS_400M, BPS_500M, BPS_1G, BPS_2G, BPS_5G, BPS_10G, BPS_20G, BPS_50G, BPS_100G, BPS_400G.
final
candidateCloudRouterIpAddress → Input<String?>?
Single IPv4 address + prefix length to be configured on the cloud router interface for this interconnect attachment. Example: 203.0.113.1/29
final
candidateCloudRouterIpv6Address → Input<String?>?
Single IPv6 address + prefix length to be configured on the cloud router interface for this interconnect attachment. Example: 2001:db8::1/125
final
candidateCustomerRouterIpAddress → Input<String?>?
Single IPv4 address + prefix length to be configured on the customer router interface for this interconnect attachment. Example: 203.0.113.2/29
final
candidateCustomerRouterIpv6Address → Input<String?>?
Single IPv6 address + prefix length to be configured on the customer router interface for this interconnect attachment. Example: 2001:db8::2/125
final
candidateSubnets → Input<List<String>?>?
Up to 16 candidate prefixes that can be used to restrict the allocation of cloudRouterIpAddress and customerRouterIpAddress for this attachment. All prefixes must be within link-local address space (169.254.0.0/16) and must be /29 or shorter (/28, /27, etc). Google will attempt to select an unused /29 from the supplied candidate prefix(es). The request will fail if all possible /29s are in use on Google's edge. If not supplied, Google will randomly select an unused /29 from all of link-local space.
final
cloudRouterIpAddress → Input<String?>?
IPv4 address + prefix length to be configured on Cloud Router Interface for this interconnect attachment.
final
cloudRouterIpv6Address → Input<String?>?
IPv6 address + prefix length to be configured on Cloud Router Interface for this interconnect attachment.
final
creationTimestamp → Input<String?>?
Creation timestamp in RFC3339 text format.
final
customerRouterIpAddress → Input<String?>?
IPv4 address + prefix length to be configured on the customer router subinterface for this interconnect attachment.
final
customerRouterIpv6Address → Input<String?>?
IPv6 address + prefix length to be configured on the customer router subinterface for this interconnect attachment.
final
deletionPolicy → Input<String?>?
Whether Terraform will be prevented from destroying the resource. Defaults to DELETE. When a 'terraform destroy' or 'pulumi up' would delete the resource, the command will fail if this field is set to "PREVENT" in Terraform state. When set to "ABANDON", the command will remove the resource from Terraform management without updating or deleting the resource in the API. When set to "DELETE", deleting the resource is allowed.
final
description → Input<String?>?
An optional description of this resource.
final
edgeAvailabilityDomain → Input<String?>?
Desired availability domain for the attachment. Only available for type PARTNER, at creation time. For improved reliability, customers should configure a pair of attachments with one per availability domain. The selected availability domain will be provided to the Partner via the pairing key so that the provisioned circuit will lie in the specified domain. If not specified, the value will default to AVAILABILITY_DOMAIN_ANY.
final
effectiveLabels → Input<Map<String, String>?>?
All of labels (key/value pairs) present on the resource in GCP, including the labels configured through Pulumi, other clients and services.
final
encryption → Input<String?>?
Indicates the user-supplied encryption option of this interconnect attachment. Can only be specified at attachment creation for PARTNER or DEDICATED attachments.
final
googleReferenceId → Input<String?>?
Google reference ID, to be used when raising support tickets with Google or otherwise to debug backend connectivity issues.
final
hashCode → int
The hash code for this object.
no setterinherited
interconnect → Input<String?>?
URL of the underlying Interconnect object that this attachment's traffic will traverse through. Required if type is DEDICATED, must not be set if type is PARTNER.
final
ipsecInternalAddresses → Input<List<String>?>?
URL of addresses that have been reserved for the interconnect attachment, Used only for interconnect attachment that has the encryption option as IPSEC. The addresses must be RFC 1918 IP address ranges. When creating HA VPN gateway over the interconnect attachment, if the attachment is configured to use an RFC 1918 IP address, then the VPN gateway's IP address will be allocated from the IP address range specified here. For example, if the HA VPN gateway's interface 0 is paired to this interconnect attachment, then an RFC 1918 IP address for the VPN gateway interface 0 will be allocated from the IP address specified for this interconnect attachment. If this field is not specified for interconnect attachment that has encryption option as IPSEC, later on when creating HA VPN gateway on this interconnect attachment, the HA VPN gateway's IP address will be allocated from regional external IP address pool.
final
l2Forwarding → Input<InterconnectAttachmentL2Forwarding?>?
L2 Interconnect Attachment related configuration. Structure is documented below.
final
labelFingerprint → Input<String?>?
A fingerprint for the labels being applied to this Interconnect, which is essentially a hash of the labels set used for optimistic locking. The fingerprint is initially generated by Compute Engine and changes after every request to modify or update labels. You must always provide an up-to-date fingerprint hash in order to update or change labels, otherwise the request will fail with error 412 conditionNotMet.
final
labels → Input<Map<String, String>?>?
Labels for this resource. These can only be added or modified by the setLabels method. Each label key/value pair must comply with RFC1035. Label values may be empty.
final
mtu → Input<String?>?
Maximum Transmission Unit (MTU), in bytes, of packets passing through this interconnect attachment. Valid values are 1440, 1460, 1500, and 8896. If not specified, the value will default to 1440.
final
name → Input<String?>?
Name of the resource. Provided by the client when the resource is created. The name must be 1-63 characters long, and comply with RFC1035. Specifically, the name must be 1-63 characters long and match the regular expression a-z? which means the first character must be a lowercase letter, and all following characters must be a dash, lowercase letter, or digit, except the last character, which cannot be a dash.
final
pairingKey → Input<String?>?
Output only for type PARTNER. Not present for DEDICATED. The opaque identifier of an PARTNER attachment used to initiate provisioning with a selected partner. Of the form "XXXXX/region/domain"
final
params → Input<InterconnectAttachmentParams?>?
Additional params passed with the request, but not persisted as part of resource payload Structure is documented below.
final
partnerAsn → Input<String?>?
Output only for type PARTNER. Not present for DEDICATED. Optional BGP ASN for the router that should be supplied by a layer 3 Partner if they configured BGP on behalf of the customer.
final
privateInterconnectInfos → Input<List<InterconnectAttachmentPrivateInterconnectInfo>?>?
Information specific to an InterconnectAttachment. This property is populated if the interconnect that this is attached to is of type DEDICATED. Structure is documented below.
final
project → Input<String?>?
The ID of the project in which the resource belongs. If it is not provided, the provider project is used.
final
pulumiLabels → Input<Map<String, String>?>?
The combination of labels configured directly on the resource and default labels configured on the provider.
final
region → Input<String?>?
Region where the regional interconnect attachment resides.
final
router → Input<String?>?
URL of the cloud router to be used for dynamic routing. This router must be in the same region as this InterconnectAttachment. The InterconnectAttachment will automatically connect the Interconnect to the network & region within which the Cloud Router is configured.
final
runtimeType → Type
A representation of the runtime type of the object.
no setterinherited
The URI of the created resource.
final
stackType → Input<String?>?
The stack type for this interconnect attachment to identify whether the IPv6 feature is enabled or not. If not specified, IPV4_ONLY will be used. This field can be both set at interconnect attachments creation and update interconnect attachment operations. Possible values are: IPV4_IPV6, IPV4_ONLY.
final
state → Input<String?>?
Output Only The current state of this attachment's functionality.
final
subnetLength → Input<int?>?
Length of the IPv4 subnet mask. Allowed values: 29 (default), 30. The default value is 29, except for Cross-Cloud Interconnect connections that use an InterconnectRemoteLocation with a constraints.subnetLengthRange.min equal to 30. For example, connections that use an Azure remote location fall into this category. In these cases, the default value is 30, and requesting 29 returns an error. Where both 29 and 30 are allowed, 29 is preferred, because it gives Google Cloud Support more debugging visibility.
final
type → Input<String?>?
The type of InterconnectAttachment you wish to create. Defaults to DEDICATED. Possible values are: DEDICATED, PARTNER, PARTNER_PROVIDER, L2_DEDICATED.
final
vlanTag8021q → Input<int?>?
The IEEE 802.1Q VLAN tag for this attachment, in the range 2-4094. When using PARTNER type this will be managed upstream.
final

Methods

noSuchMethod(Invocation invocation) → dynamic
Invoked when a nonexistent method or property is accessed.
inherited
toMap() → Map<String, dynamic>
toString() → String
A string representation of this object.
inherited

Operators

operator ==(Object other) → bool
The equality operator.
inherited