GlobalAddressState class
Input properties used for looking up and filtering GlobalAddress resources.
Constructors
-
GlobalAddressState({Input<
String?> ? address, Input<String?> ? addressType, Input<String?> ? creationTimestamp, Input<String?> ? deletionPolicy, Input<String?> ? description, Input<Map< ? effectiveLabels, Input<String, String> ?>String?> ? ipVersion, Input<String?> ? labelFingerprint, Input<Map< ? labels, Input<String, String> ?>String?> ? name, Input<String?> ? network, Input<int?> ? prefixLength, Input<String?> ? project, Input<Map< ? pulumiLabels, Input<String, String> ?>String?> ? purpose, Input<String?> ? selfLink}) -
Creates a new GlobalAddressState.
addressThe IP address or beginning of the address range represented by thisaddressTypeThe type of the address to reserve.creationTimestampCreation timestamp in RFC3339 text format.deletionPolicyWhether Terraform will be prevented from destroying the resource. Defaults to DELETE.descriptionAn optional description of this resource.effectiveLabelsAll of labels (key/value pairs) present on the resource in GCP, including the labels configured through Pulumi, other clients and services.ipVersionThe IP Version that will be used by this address. The default value isIPV4.labelFingerprintThe fingerprint used for optimistic locking of this resource. UsedlabelsLabels to apply to this address. A list of key->value pairs.nameName of the resource. Provided by the client when the resource isnetworkThe URL of the network in which to reserve the IP range. The IP rangeprefixLengthThe prefix length of the IP range. If not present, it means theprojectThe ID of the project in which the resource belongs.pulumiLabelsThe combination of labels configured directly on the resourcepurposeThe purpose of the resource. Possible values include:selfLinkThe URI of the created resource.const -
GlobalAddressState.fromMap(Map<
String, dynamic> map) -
factory
Properties
-
address
→ Input<
String?> ? -
The IP address or beginning of the address range represented by this
resource. This can be supplied as an input to reserve a specific
address or omitted to allow GCP to choose a valid one for you.
final
-
addressType
→ Input<
String?> ? -
The type of the address to reserve.
final
-
creationTimestamp
→ Input<
String?> ? -
Creation timestamp in RFC3339 text format.
final
-
deletionPolicy
→ Input<
String?> ? -
Whether Terraform will be prevented from destroying the resource. Defaults to DELETE.
When a 'terraform destroy' or 'pulumi up' would delete the resource,
the command will fail if this field is set to "PREVENT" in Terraform state.
When set to "ABANDON", the command will remove the resource from Terraform
management without updating or deleting the resource in the API.
When set to "DELETE", deleting the resource is allowed.
final
-
description
→ Input<
String?> ? -
An optional description of this resource.
final
-
effectiveLabels
→ Input<
Map< ?String, String> ?> -
All of labels (key/value pairs) present on the resource in GCP, including the labels configured through Pulumi, other clients and services.
final
- hashCode → int
-
The hash code for this object.
no setterinherited
-
ipVersion
→ Input<
String?> ? -
The IP Version that will be used by this address. The default value is
IPV4. Possible values are:IPV4,IPV6.final -
labelFingerprint
→ Input<
String?> ? -
The fingerprint used for optimistic locking of this resource. Used
internally during updates.
final
-
labels
→ Input<
Map< ?String, String> ?> -
Labels to apply to this address. A list of key->value pairs.
final
-
name
→ Input<
String?> ? -
Name of the resource. Provided by the client when the resource is
created. The name must be 1-63 characters long, and comply with
RFC1035. Specifically, the name must be 1-63 characters long and
match the regular expression
a-z?which means the first character must be a lowercase letter, and all following characters must be a dash, lowercase letter, or digit, except the last character, which cannot be a dash.final -
network
→ Input<
String?> ? -
The URL of the network in which to reserve the IP range. The IP range
must be in RFC1918 space. The network cannot be deleted if there are
any reserved IP ranges referring to it.
This should only be set when using an Internal address.
final
-
prefixLength
→ Input<
int?> ? -
The prefix length of the IP range. If not present, it means the
address field is a single IP address.
This field is not applicable to addresses with addressType=INTERNAL
when purpose=PRIVATE_SERVICE_CONNECT
final
-
project
→ Input<
String?> ? -
The ID of the project in which the resource belongs.
If it is not provided, the provider project is used.
final
-
pulumiLabels
→ Input<
Map< ?String, String> ?> -
The combination of labels configured directly on the resource
and default labels configured on the provider.
final
-
purpose
→ Input<
String?> ? -
The purpose of the resource. Possible values include:
final
- runtimeType → Type
-
A representation of the runtime type of the object.
no setterinherited
-
selfLink
→ Input<
String?> ? -
The URI of the created resource.
final
Methods
-
noSuchMethod(
Invocation invocation) → dynamic -
Invoked when a nonexistent method or property is accessed.
inherited
-
toMap(
) → Map< String, dynamic> -
toString(
) → String -
A string representation of this object.
inherited
Operators
-
operator ==(
Object other) → bool -
The equality operator.
inherited