Map4dMap for Flutter

map4d platform pub package github issues

A Flutter plugin that provides a Map4dMap widget.

Usage

To use this plugin, add map4d_map as a dependency in your pubspec.yaml file.

dependencies:
  map4d_map: ^2.3.0

Minium Android/iOS SDK version support

Android

Required Android SDK 21 or higher

Set minSdkVersion in android/app/build.gradle

android {
    defaultConfig {
        minSdkVersion 21
    }
}

iOS

Required iOS 9.3 or higher

Setup API key

The API key is a unique identifier that authenticates requests associated with your project for usage and billing purposes. You must have at least one API key associated with your project.

Get an API key at map.map4d.vn/user/access-key/

Android

Provide access key from android/app/src/main/AndroidManifest.xml

<manifest xmlns:android="http://schemas.android.com/apk/res/android">
    <application>
        <meta-data
            android:name="vn.map4d.map.ACCESS_KEY"
            android:value="YOUR_KEY_HERE"/>
    </application>
</manifest>

iOS

Provide access key from ios/Runner/Info.plist

<key>Map4dMapAccessKey</key>
<string>YOUR_KEY_HERE</string>

Simple Usage

import 'package:flutter/material.dart';
import 'package:map4d_map/map4d_map.dart';

void main() {
  runApp(MyApp());
}

class MyApp extends StatelessWidget {
  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      title: 'Map4D Map',
      home: MFMapView(),
    );
  }
}

See example directory for more examples

Documents

Libraries

map4d_map