flutter_essentials_kit

A kit of useful functions and widget to speed up development.

Pub Dart CI License: MIT

Getting Started

Add this to your package's pubspec.yaml file:

dependencies:
  flutter_essentials_kit:

Usage

Just use this import to use the package:

import 'package:flutter_essentials_kit/flutter_essentials_kit.dart';

Plug the localization class in your localizationsDelegates.

import 'package:flutter_essentials_kit/flutter_essentials_kit.dart';

MaterialApp(
  localizationsDelegates: [
    // ...
    FlutterEssentialsKitLocalizations.delegate,
    // ...
);

Docs

Libraries

color
commons
confimed_rule_error
confirmed_rule
courtesy_widget
data_rule
data_rule_error
date_time
email_rule
email_rule_error
flutter_essentials_kit
flutter_essentials_kit_localizations
flutter_essentials_kit_localizations_de
flutter_essentials_kit_localizations_en
flutter_essentials_kit_localizations_fr
flutter_essentials_kit_localizations_it
iterable
localized
localized_error
localized_exception
max_rule
max_rule_error
min_rule
min_rule_error
regex_rule
regex_rule_error
required_rule
required_rule_error
same_rule
same_rule_error
size_rule
size_rule_error
spacing
trim_rule
two_way_binding
two_way_binding_builder