url_param: A Library For Dart/Flutter Developers.

Coverage pub.dev GitHub stars GitHub license

use as following

Add this to your package's pubspec.yaml file under dependency:

dependencies:
  url_param: ^1.0.3

Install it

You can install packages from the command line:

with Flutter:

flutter pub get

Import it

Now in your Dart code, you can use:

import 'package:url_params/params.dart';

Use it like below example

void main() {
  var query =  URLParams();
  query.append('key', 'value');
  var result = query.toUrl('https://cdn.example.io');
  print(result);
}

Features and bugs

Please file feature requests and bugs at the tracker. tracker: https://github.com/ishaileshmishra/url_params/issues

Libraries

params
You can use this package to add query parameters to the urls [...]