Surf Lint Rules

Build Status Pub Version Pub Likes Pub popularity Dart Platform Flutter Platform

This package is part of the SurfGear toolkit made by Surf.

About

Lint rules for "Surf" company.

Installation

Add surf_lint_rules as dependency to your pubspec.yaml

dev_dependencies:
  surf_lint_rules: ^1.0.0

You can use both stable and dev versions of the package listed above in the badges bar.

Create analysis_options.yaml file

include: package:surf_lint_rules/analysis_options.yaml

See the dartanalyzer executing the lint checks in you favorite editor.

Changelog

All notable changes to this project will be documented in this file.

Issues

For issues, file directly in the main SurfGear repo.

Contribute

If you would like to contribute to the package (e.g. by improving the documentation, solving a bug or adding a cool new feature), please review our contribution guide first and send us your pull request.

Your PRs are always welcome.

How to reach us

Please feel free to ask any questions about this package. Join our community chat on Telegram. We speak English and Russian.

Telegram

License

Apache License, Version 2.0

Libraries

surf_lint_rules