supabase_flutter_addons

Make great apps with a great backend!

Installation

Add the dependencies:

dependencies:
  supabase: <latest-version>
  supabase_addons: <latest-version>
  supabase_flutter_addons: <latest-version>

and import the packages:

import 'package:supabase/supabase.dart';
import 'package:supabase_addons/supabase_addons.dart';
import 'package:supabase_flutter_addons/supabase_flutter_addons.dart';

Get started

Initialize the addons.

await SupabaseAddonsFlutter.initialize(
  client: SupabaseClient(SUPABASE_URL, SUPABASE_SECRET),
);

And you're good to go!

Refer to supabase_addons documentation to learn more.

You don't need to call SupabaseAddons.initialize if you already called SupabaseAddonsFlutter.initialize

To dispose the addons, call

SupabaseAddons.dispose();

Features and bugs

Please file feature requests and bugs at the issue tracker.

Libraries

supabase_addons_flutter