SubjectAltNamesResponse constructor

const SubjectAltNamesResponse({
  1. required Input<List<X509ExtensionResponse>> customSans,
  2. required Input<List<String>> dnsNames,
  3. required Input<List<String>> emailAddresses,
  4. required Input<List<String>> ipAddresses,
  5. required Input<List<String>> uris,
})

Creates a new SubjectAltNamesResponse. customSans Contains additional subject alternative name values. For each custom_san, the value field must contain an ASN.1 encoded UTF8String. dnsNames Contains only valid, fully-qualified host names. emailAddresses Contains only valid RFC 2822 E-mail addresses. ipAddresses Contains only valid 32-bit IPv4 addresses or RFC 4291 IPv6 addresses. uris Contains only valid RFC 3986 URIs.

Implementation

const SubjectAltNamesResponse({
  required this.customSans,
  required this.dnsNames,
  required this.emailAddresses,
  required this.ipAddresses,
  required this.uris,
});