netglade

Developed with 💚 by netglade

ci pub package license: MIT style: netglade analysis Discord


Lint rules for Dart and Flutter used internally at netglade.

You can also check all the available Dart lint rules on linter rules site or supported lint rules site. And you can see all the available on DCM rules site.

Usage

To use the lints, add as a dev dependency in your pubspec.yaml:

dev_dependencies:
  netglade_analysis: ^7.0.0

Then, add an include in analysis_options.yaml:

include: package:netglade_analysis/lints.yaml

To also use Dart Code Metrics, add configuration in analysis_options.yaml. Then you can use its CLI tool.

dart_code_metrics:
  extends:
    - package:netglade_analysis/dcm.yaml

Recommendations

Consider adding an analyzer exclude for generated, coverage, ... files.

analyzer:
  exclude:
    - '**/*.g.dart'
    - '**/*.freezed.dart'
    - test/.test_coverage.dart
    - lib/generated_plugin_registrant.dart

Badge

To indicate your project is using netglade_analysisstyle: netglade analysis

[![style: netglade analysis](https://img.shields.io/badge/style-netglade_analysis-26D07C.svg)](https://pub.dev/packages/netglade_analysis)

Libraries

netglade_analysis
NetGlade Dart and Flutter analyzer settings and best practices used internally at netglade.