flutter_l10n

Flutter localizations.

Getting Started

Install

dev_dependencies:
  ...
  flutter_l10n: '^0.1.3'

Usage

  1. Generate S.dart file from *.arb files.
    flutter pub run flutter_l10n:build.

  2. Register in MaterialApp/WidgetsApp:

MaterialApp(
  localizationsDelegates: [
    S.delegate,
  ],
);
  1. Reference strings by S.of(context).***.

Libraries

log
reader
writer