Elementary CLI

CLI utilities for Elementary

Installation

Directly using cli

Run dart pub global activate elementary_cli or flutter pub global activate elementary_cli

Using with elementary plugin for VSCode

Run dart pub global activate elementary_cli

Using with elementary plugin for Intellij

Run flutter pub global activate elementary_cli

Integration

The only option for now is exit codes. You can find full list of exceptions and exit codes in exit_code_exception.dart file.

Libraries

console_writer
elementary_plugin
exit_code_exception
generate
generate_module
generate_test
generate_test_wm
start_elementary_plugin