easy_buttons

Getting started

ClassFunc first package library

demo_easy_buttons

Usage

  • Install
flutter pub add easy_buttons

dependencies:
  easy_buttons: ^1.0.8
  
  • Use package
import 'package:easy_buttons/easy_buttons.dart';


EasyButton(
          title: 'Test new packages',
          svgPicture: SvgPicture.asset('assets/images/ic_done_bottom.svg', width: 30, height: 32),
          onTap: () => showDialog<String>(
            context: context,
            builder: (BuildContext context) => AlertDialog(
              title: const Text('AlertDialog Title'),
              content: const Text('AlertDialog description'),
              actions: <Widget>[
                TextButton(
                  onPressed: () => Navigator.pop(context, 'Cancel'),
                  child: const Text('Cancel'),
                ),
                TextButton(
                  onPressed: () => Navigator.pop(context, 'OK'),
                  child: const Text('OK'),
                ),
              ],
            ),
          ),
        ),

Additional information

ClassFunc button package for flutter ^.^

Libraries

constants
easy_buttons