contextual_menu

pub version

This plugin allows Flutter desktop apps to create native context menus.


English | 简体中文


Platform Support

LinuxmacOSWindows
✔️✔️✔️

Screenshots

macOSLinuxWindows
image

Quick Start

Installation

Add this to your package's pubspec.yaml file:

dependencies:
  contextual_menu: ^0.1.1

Or

dependencies:
  contextual_menu:
    git:
      url: https://github.com/leanflutter/contextual_menu.git
      ref: main

Usage

import 'package:flutter/material.dart' hide MenuItem;
import 'package:contextual_menu/contextual_menu.dart';

Menu menu = Menu(
  items: [
    MenuItem(
      label: 'Copy',
      onClick: (_) {
        print('Clicked Copy');
      },
    ),
    MenuItem(
      label: 'Disabled item',
      disabled: true,
    ),
     MenuItem.checkbox(
      key: 'checkbox1',
      label: 'Checkbox1',
      checked: true,
      onClick: (menuItem) {
        print('Clicked Checkbox1');
        menuItem.checked = !(menuItem.checked == true);
      },
    ),
    MenuItem.separator(),
  ],
);

popUpContextualMenu(
  _menu!,
  placement: Placement.bottomLeft,
);

Please see the example app of this plugin for a full example.

Who's using it?

Related Links

License

MIT

Libraries

contextual_menu