connectivity_macos

The macos implementation of `connectivity`.

Please set your constraint to connectivity_macos: '>=0.1.y+x <2.0.0'

Backward compatible 1.0.0 version is coming

The plugin has reached a stable API, we guarantee that version 1.0.0 will be backward compatible with 0.1.y+z. Please use connectivity_macos: '>=0.1.y+x <2.0.0' as your dependency constraint to allow a smoother ecosystem migration. For more details see: https://github.com/flutter/flutter/wiki/Package-migration-to-1.0.0

Usage

Import the package

This package has been endorsed, meaning that you only need to add connectivity as a dependency in your pubspec.yaml. It will be automatically included in your app when you depend on package:connectivity.

This is what the above means to your pubspec.yaml:

...
dependencies:
  ...
  connectivity: ^0.4.8
  ...

Refer to the connectivity documentation for more details.

Libraries

connectivity_macos