zpl_composer 0.0.1-beta.1

  • Readme
  • Changelog
  • Installing
  • 41

ZPL Composer #

A ZPL composer package

Getting Started #

This package aims to facilitate the life developers who want to dynamically builds ZPL templates

This package can help you building ZPL templates in a very Flutter friendly way

Installation #

dependencies:
  flutter:
    sdk: flutter
  zpl_composer: ^0.0.1

Example #

import 'package:zpl_composer/zpl_composer';

final _page = Page(
  child: Column(
    children: [
      Text(
          'Title',
          isBold: true,
          fontSize: 25,
        ),
      ),
      for (Product product in _products)
      	Row(
          children: [
            Flex(
              child: Text('Name'),
            ),
            Flex(
              align: FlexAlign.right,
              child: Text(_product.name),
            ),
          ],
        ),
    ],
  ),
),

_page.getString(); // ^XA^CFA,1^FO0,0,^FDTitle^FS^XZ

[0.0.1-beta.1] - First beta release #

  • The first beta initial release (Contains only Text and Page components)

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  zpl_composer: ^0.0.1-beta.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:zpl_composer/zpl_composer.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
55
Overall:
Weighted score of the above. [more]
41
Learn more about scoring.

We analyzed this package on Jul 7, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13
  • Flutter: 1.17.5

Analysis suggestions

Package not compatible with SDK dart

because of import path [zpl_composer] that is in a package requiring null.

Health issues and suggestions

Document public APIs. (-1 points)

1 out of 1 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Format lib/src/components/flex.dart.

Run flutter format to format lib/src/components/flex.dart.

Format lib/src/components/image.dart.

Run flutter format to format lib/src/components/image.dart.

Format lib/src/components/row.dart.

Run flutter format to format lib/src/components/row.dart.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and zpl_composer.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Package is pre-release. (-5 points)

Pre-release versions should be used with caution; their API can change in breaking ways.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.7.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8 1.2.1
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8
Dev dependencies
flutter_test
mockito ^4.1.1