z_components 0.9.31+1
z_components: ^0.9.31+1 copied to clipboard

Z_Components is a package that contains a set of standardized components to facilitate, optimize, and accelerate the development of Zellar company's Android / IOS applications.

4
likes
40 / 110
pub points
57 %
popularity

We analyzed this package on Feb 13, 2021, and awarded it 40 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: Failed to run dartdoc

  • Running dartdoc failed with the following output:

Support multiple platforms
0 / 20

0/20 points: Supports 0 of 2 possible platforms (native, js)

Package resolution failed. Could not determine platforms.

Run pub get for more information.

Pass static analysis
0 / 30

0/30 points: code has no errors, warnings, lints, or formatting issues

Found 12076 issues. Showing the first 2:

ERROR: Target of URI doesn't exist: 'package:z_components/api/arquivo/i-arquivo-service.dart'.

lib/api/arquivo/arquivo-service.dart:2:8

  ╷
2 │ import 'package:z_components/api/arquivo/i-arquivo-service.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/api/arquivo/arquivo-service.dart

ERROR: Target of URI doesn't exist: 'package:z_components/api/service.dart'.

lib/api/arquivo/arquivo-service.dart:3:8

  ╷
3 │ import 'package:z_components/api/service.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/api/arquivo/arquivo-service.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

  • Could not run pub outdated: pub get failed:
Because z_components depends on flutter_localizations any from sdk which depends on intl 0.17.0-nullsafety.2, intl 0.17.0-nullsafety.2 is required.
So, because z_components depends on intl ^0.16.0, version solving failed.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.14.10, Flutter 1.25.0-8.3.pre, Dart 2.12.0 (build 2.12.0-133.7.beta).